summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-01-14 11:37:29 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-01-14 11:37:29 +0000
commit91b79128dc8f55a42818b775649ec893eb4f2fe8 (patch)
treecd6d91fc0f20ad2f2eb23416408b21c07232b60e /target/linux/mvebu/image/Makefile
parent5b0849b97f84efc8b83910529368f063e112638e (diff)
downloadmaster-31e0f0ae-91b79128dc8f55a42818b775649ec893eb4f2fe8.tar.gz
master-31e0f0ae-91b79128dc8f55a42818b775649ec893eb4f2fe8.tar.bz2
master-31e0f0ae-91b79128dc8f55a42818b775649ec893eb4f2fe8.zip
mvebu: Replace the padjffs2 call by the generic definition
The mvebu image Makefile directly calls the padjffs2 utility, while there's an generic make function to do just that. Switch to it Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> SVN-Revision: 43968
Diffstat (limited to 'target/linux/mvebu/image/Makefile')
-rw-r--r--target/linux/mvebu/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 92571e2153..f265dc43d2 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -44,7 +44,7 @@ define Image/BuildKernel
endef
define Image/Build/squashfs
- $(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR)/root.squashfs 128
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
$(foreach nandboard,$(NANDBOARDS),$(call Image/Build/UbinizeImage,$(nandboard),,squashfs,$(UBI_OPTS));)
( \
dd if=$(KDIR)/uImage-armada-xp-mamba bs=3072k conv=sync; \