summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-12-11 15:29:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-12-11 15:29:39 +0000
commit2d9d3e7163deb2e6eac036587f63201eaa23c9d9 (patch)
treedb8964e9bb12c6b15985fd05d5bbaead88e6cad0 /target/linux/mpc85xx
parent9318930993ed2075188b98c476d9ed8b90344e9f (diff)
downloadmaster-31e0f0ae-2d9d3e7163deb2e6eac036587f63201eaa23c9d9.tar.gz
master-31e0f0ae-2d9d3e7163deb2e6eac036587f63201eaa23c9d9.tar.bz2
master-31e0f0ae-2d9d3e7163deb2e6eac036587f63201eaa23c9d9.zip
mpc85xx: fix initramfs images
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43620
Diffstat (limited to 'target/linux/mpc85xx')
-rw-r--r--target/linux/mpc85xx/Makefile2
-rw-r--r--target/linux/mpc85xx/image/Makefile14
2 files changed, 8 insertions, 8 deletions
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index d027e49f11..001de825b6 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -16,6 +16,8 @@ SUBTARGETS=generic p1020
KERNEL_PATCHVER:=3.14
+KERNEL_IMAGES := zImage cuImage.tl-wdr4900-v1
+
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += \
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index dcb2620a67..ae8b8374b2 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -22,21 +22,19 @@ endef
zImage:=$(BIN_DIR)/$(IMG_PREFIX)-zImage
DTS_TARGETS = mpc8548cds_32b p1010rdb-pa tl-wdr4900-v1 p1020rdb
-BOOT_IMAGES:=zImage cuImage.tl-wdr4900-v1
-
-define Image/Prepare
- $(foreach image,$(BOOT_IMAGES),
- cp $(LINUX_DIR)/arch/powerpc/boot/$(image) $(KDIR)/$(image)
- )
-endef
define Image/BuildKernel
- cp $(KDIR)/zImage $(zImage)
+ cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
$(foreach dts,$(DTS_TARGETS),
$(LINUX_DIR)/scripts/dtc/dtc -I dts -O dtb $(DTS_DIR)/$(dts).dts > $(BIN_DIR)/$(IMG_PREFIX)-$(dts).fdt
)
endef
+define Image/BuildKernel
+ cp $(KDIR)/zImage-initramfs $(BIN_DIR)/$(IMG_PREFIX)-initramfs-zImage
+ cp $(KDIR)/cuImage.tl-wdr4900-v1-initramfs $(BIN_DIR)/$(IMG_PREFIX)-tl-wdr4900-initramfs.uImage
+endef
+
define Image/Build/TPLINK
-$(STAGING_DIR_HOST)/bin/mktplinkfw \
-H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) $(7) \