summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-12-01 09:59:53 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-12-01 09:59:53 +0000
commitf1ef0b92bef17f09fe61e1d2e8275d5fdb4c9cc8 (patch)
tree29e748c94381371d6ec2f7dd4cfcc030e1c698ba /target/linux/mpc85xx
parentf51d78f4f2e91658985288b95f572da9b7a021ae (diff)
downloadmaster-31e0f0ae-f1ef0b92bef17f09fe61e1d2e8275d5fdb4c9cc8.tar.gz
master-31e0f0ae-f1ef0b92bef17f09fe61e1d2e8275d5fdb4c9cc8.tar.bz2
master-31e0f0ae-f1ef0b92bef17f09fe61e1d2e8275d5fdb4c9cc8.zip
kernel: update 3.10 to 3.10.21
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38972
Diffstat (limited to 'target/linux/mpc85xx')
-rw-r--r--target/linux/mpc85xx/Makefile2
-rw-r--r--target/linux/mpc85xx/patches-3.10/200-fix_gianfar_napi_poll.patch4
2 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index 3e7cd38029..2f4bcc92d1 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
SUBTARGETS=generic p1020
-LINUX_VERSION:=3.10.18
+LINUX_VERSION:=3.10.21
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/mpc85xx/patches-3.10/200-fix_gianfar_napi_poll.patch b/target/linux/mpc85xx/patches-3.10/200-fix_gianfar_napi_poll.patch
index a1877be921..77cbc67ebc 100644
--- a/target/linux/mpc85xx/patches-3.10/200-fix_gianfar_napi_poll.patch
+++ b/target/linux/mpc85xx/patches-3.10/200-fix_gianfar_napi_poll.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/ethernet/freescale/gianfar.c
+++ b/drivers/net/ethernet/freescale/gianfar.c
-@@ -2835,7 +2835,7 @@ static int gfar_poll(struct napi_struct
+@@ -2835,7 +2835,7 @@ static int gfar_poll(struct napi_struct
struct gfar_priv_rx_q *rx_queue = NULL;
int work_done = 0, work_done_per_q = 0;
int i, budget_per_q = 0;
@@ -9,7 +9,7 @@
unsigned long rstat_rxf;
int num_act_queues;
-@@ -2850,62 +2850,48 @@ static int gfar_poll(struct napi_struct
+@@ -2850,62 +2850,48 @@ static int gfar_poll(struct napi_struct
if (num_act_queues)
budget_per_q = budget/num_act_queues;