summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/profiles
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-03-15 16:11:45 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-03-15 16:11:45 +0000
commit1996cfe9dd27d6f369983bb024b31f01acd0e267 (patch)
treeffa20c772560be68d66b85b747e908f13ba551aa /target/linux/mpc85xx/profiles
parent72253b907330ab12ffbfca9761e95920579a0ffe (diff)
downloadmaster-31e0f0ae-1996cfe9dd27d6f369983bb024b31f01acd0e267.tar.gz
master-31e0f0ae-1996cfe9dd27d6f369983bb024b31f01acd0e267.tar.bz2
master-31e0f0ae-1996cfe9dd27d6f369983bb024b31f01acd0e267.zip
mpc85xx: add profile and build image for the TL-WDR4900 v1 board
Now that the ethernet switch is working, create firmware images to make impatient users happy. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 36051
Diffstat (limited to 'target/linux/mpc85xx/profiles')
-rw-r--r--target/linux/mpc85xx/profiles/tp-link.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/profiles/tp-link.mk b/target/linux/mpc85xx/profiles/tp-link.mk
new file mode 100644
index 0000000000..57981d377c
--- /dev/null
+++ b/target/linux/mpc85xx/profiles/tp-link.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/TLWDR4900
+ NAME:=TP-Link TL-WDR4900
+ PACKAGES:=\
+ kmod-usb-core kmod-usb2 kmod-usb2-fsl \
+ kmod-ath9k kmod-wpad
+endef
+
+define Profile/TLWDR4900/Description
+ Package set optimized for the TP-Link TL-WDR4900.
+endef
+$(eval $(call Profile,TLWDR4900))