summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-19 14:53:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-19 14:53:15 +0000
commit69cc70a43c41bd2116cf4d807a0bff58167a41b9 (patch)
treeca9caac05223da8e0bb4036cdbba962c2fe806a3 /target/linux/mpc85xx/image
parentae9100e9691e427aaf5bbb996214b5ec74748fa1 (diff)
downloadmaster-31e0f0ae-69cc70a43c41bd2116cf4d807a0bff58167a41b9.tar.gz
master-31e0f0ae-69cc70a43c41bd2116cf4d807a0bff58167a41b9.tar.bz2
master-31e0f0ae-69cc70a43c41bd2116cf4d807a0bff58167a41b9.zip
mpc85xx: enable squashfs feature
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35675
Diffstat (limited to 'target/linux/mpc85xx/image')
-rw-r--r--target/linux/mpc85xx/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index 45cd7abdc2..b762515ec3 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -24,6 +24,11 @@ define Image/Build/ext2
cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-ext2.img
endef
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ cp $(KDIR)/root.squashfs $(BIN_DIR)/$(IMG_PREFIX)-root.squashfs
+endef
+
define Image/Build
$(call Image/Build/$(1),$(1))
endef