summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-01-23 06:55:58 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-01-23 06:55:58 +0000
commit53512a19610cec1248fddbc8c2d6896f33e29a9f (patch)
tree21da8b67361a49c2733e3c64248915ff6445db9d /target/linux/mpc85xx/image
parent30af45d19a80e00225d245c03bee3f21c55a1a99 (diff)
downloadmaster-31e0f0ae-53512a19610cec1248fddbc8c2d6896f33e29a9f.tar.gz
master-31e0f0ae-53512a19610cec1248fddbc8c2d6896f33e29a9f.tar.bz2
master-31e0f0ae-53512a19610cec1248fddbc8c2d6896f33e29a9f.zip
mpc85xx: Fix building ramdisk images
Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 39368
Diffstat (limited to 'target/linux/mpc85xx/image')
-rw-r--r--target/linux/mpc85xx/image/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index 4c80bb777f..5ecd100355 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -19,11 +19,7 @@ define factoryname
$(call imgname,$(1),$(2))-factory.bin
endef
-ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
- IMAGE_SUFFIX=-initramfs
-endif
-
-zImage:=$(BIN_DIR)/$(IMG_PREFIX)-zImage$(IMAGE_SUFFIX)
+zImage:=$(BIN_DIR)/$(IMG_PREFIX)-zImage
DTS_TARGETS = mpc8548cds_32b p1010rdb tl-wdr4900-v1 p1020rdb
BOOT_IMAGES:=zImage cuImage.tl-wdr4900-v1
@@ -35,7 +31,7 @@ define Image/Prepare
endef
define Image/BuildKernel
- cp $(KDIR)/zImage$(IMAGE_SUFFIX) $(zImage)
+ cp $(KDIR)/zImage $(zImage)
$(foreach dts,$(DTS_TARGETS),
$(LINUX_DIR)/scripts/dtc/dtc -I dts -O dtb $(LINUX_DIR)/arch/powerpc/boot/dts/$(dts).dts > $(BIN_DIR)/$(IMG_PREFIX)-$(dts).fdt
)