summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-16 18:04:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-16 18:04:54 +0000
commit2b6a84a7a388a5059657d44253a27f92f3322488 (patch)
tree865350699187b6e976e67ff2549138ccb42bec64 /target/linux/mpc85xx/image
parent733f2f8c762c7e9cfd8ff60c4a53e165c88d320c (diff)
downloadmaster-31e0f0ae-2b6a84a7a388a5059657d44253a27f92f3322488.tar.gz
master-31e0f0ae-2b6a84a7a388a5059657d44253a27f92f3322488.tar.bz2
master-31e0f0ae-2b6a84a7a388a5059657d44253a27f92f3322488.zip
mpc85xx: copy the fdt for mpc8548cds to $(BIN_DIR)
SVN-Revision: 26191
Diffstat (limited to 'target/linux/mpc85xx/image')
-rw-r--r--target/linux/mpc85xx/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index bb9904572c..a5d1acbd5c 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -7,12 +7,15 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+DTS_TARGETS = mpc8548cds
+
define Image/Prepare
cp $(LINUX_DIR)/arch/powerpc/boot/zImage $(KDIR)/zImage
endef
define Image/BuildKernel
cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+ $(foreach dts,$(DTS_TARGETS),$(LINUX_DIR)/scripts/dtc/dtc -I dts -O dtb $(LINUX_DIR)/arch/powerpc/boot/dts/$(dts).dts > $(BIN_DIR)/$(IMG_PREFIX)-$(dts).fdt)
endef
define Image/Build/ext2