summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc83xx/patches-3.8/100-powerpc_create_fit_uImages.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-21 20:39:22 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-21 20:39:22 +0000
commit9ec9adf3ea4c51fc0e9aece21110b05f57bd76af (patch)
treec1e66354b5a2f0c433bb23113626c39fe4daf9e3 /target/linux/mpc83xx/patches-3.8/100-powerpc_create_fit_uImages.patch
parentc50881d7ba35ccd9e9ed07f3b76f66ce3a4f55de (diff)
downloadmaster-31e0f0ae-9ec9adf3ea4c51fc0e9aece21110b05f57bd76af.tar.gz
master-31e0f0ae-9ec9adf3ea4c51fc0e9aece21110b05f57bd76af.tar.bz2
master-31e0f0ae-9ec9adf3ea4c51fc0e9aece21110b05f57bd76af.zip
mpc83xx: add support for 3.8
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35736
Diffstat (limited to 'target/linux/mpc83xx/patches-3.8/100-powerpc_create_fit_uImages.patch')
-rw-r--r--target/linux/mpc83xx/patches-3.8/100-powerpc_create_fit_uImages.patch85
1 files changed, 85 insertions, 0 deletions
diff --git a/target/linux/mpc83xx/patches-3.8/100-powerpc_create_fit_uImages.patch b/target/linux/mpc83xx/patches-3.8/100-powerpc_create_fit_uImages.patch
new file mode 100644
index 0000000000..9cba984618
--- /dev/null
+++ b/target/linux/mpc83xx/patches-3.8/100-powerpc_create_fit_uImages.patch
@@ -0,0 +1,85 @@
+--- a/arch/powerpc/Makefile
++++ b/arch/powerpc/Makefile
+@@ -155,7 +155,9 @@ all: zImage
+
+ # With make 3.82 we cannot mix normal and wildcard targets
+ BOOT_TARGETS1 := zImage zImage.initrd uImage
+-BOOT_TARGETS2 := zImage% dtbImage% treeImage.% cuImage.% simpleImage.% uImage.%
++BOOT_TARGETS2 := uImage.fit.% zImage% dtbImage% treeImage.% cuImage.% \
++ simpleImage.% uImage.%
++
+
+ PHONY += $(BOOT_TARGETS1) $(BOOT_TARGETS2)
+
+@@ -188,6 +190,7 @@ define archhelp
+ @echo '* zImage - Build default images selected by kernel config'
+ @echo ' zImage.* - Compressed kernel image (arch/$(ARCH)/boot/zImage.*)'
+ @echo ' uImage - U-Boot native image format'
++ @echo ' uImage.fit.<dt> - U-Boot Flattened Image Tree image format'
+ @echo ' cuImage.<dt> - Backwards compatible U-Boot image for older'
+ @echo ' versions which do not support device trees'
+ @echo ' dtbImage.<dt> - zImage with an embedded device tree blob'
+--- a/arch/powerpc/boot/.gitignore
++++ b/arch/powerpc/boot/.gitignore
+@@ -14,6 +14,7 @@ kernel-vmlinux.strip.c
+ kernel-vmlinux.strip.gz
+ mktree
+ uImage
++uImage.fit.*
+ cuImage.*
+ dtbImage.*
+ treeImage.*
+--- a/arch/powerpc/boot/Makefile
++++ b/arch/powerpc/boot/Makefile
+@@ -338,6 +338,9 @@ $(obj)/uImage.initrd.%: vmlinux $(obj)/%
+ $(obj)/uImage.%: vmlinux $(obj)/%.dtb $(wrapperbits)
+ $(call if_changed,wrap,uboot-$*,,$(obj)/$*.dtb)
+
++$(obj)/uImage.fit.%: vmlinux $(obj)/%.dtb $(wrapperbits)
++ $(call if_changed,wrap,uboot.fit,,$(obj)/$*.dtb)
++
+ $(obj)/cuImage.initrd.%: vmlinux $(obj)/%.dtb $(wrapperbits)
+ $(call if_changed,wrap,cuboot-$*,,$(obj)/$*.dtb,$(obj)/ramdisk.image.gz)
+
+@@ -375,6 +378,7 @@ install: $(CONFIGURE) $(addprefix $(obj)
+
+ # anything not in $(targets)
+ clean-files += $(image-) $(initrd-) cuImage.* dtbImage.* treeImage.* \
++ uImage.* \
+ zImage zImage.initrd zImage.chrp zImage.coff zImage.holly \
+ zImage.miboot zImage.pmac zImage.pseries \
+ zImage.maple simpleImage.* otheros.bld *.dtb
+--- a/arch/powerpc/boot/wrapper
++++ b/arch/powerpc/boot/wrapper
+@@ -47,6 +47,9 @@ CROSS=
+ # mkimage wrapper script
+ MKIMAGE=$srctree/scripts/mkuboot.sh
+
++# script to generate an .its file for uImage.fit.* images
++MKITS=$srctree/scripts/mkits.sh
++
+ # directory for object and other files used by this script
+ object=arch/powerpc/boot
+ objbin=$object
+@@ -336,6 +339,21 @@ uboot-obs600)
+ if [ -z "$cacheit" ]; then
+ rm -f "$vmz"
+ fi
++ exit 0
++ ;;
++uboot.fit)
++ rm -f "$ofile"
++ ${MKITS} -A ppc -C gzip -a $membase -e $membase -v $version \
++ -d "$srctree/$dtb" -k "$srctree/$vmz" -o "$object/uImage.its"
++
++ # mkimage calls dtc for FIT images so use kernel dtc if necessary
++ export PATH=$PATH:$srctree/scripts/dtc
++
++ ${MKIMAGE} -f "$object/uImage.its" "$ofile"
++ rm "$object/uImage.its"
++ if [ -z "$cacheit" ]; then
++ rm -f "$vmz"
++ fi
+ exit 0
+ ;;
+ esac