summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc83xx/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2010-01-10 16:02:11 +0000
committerImre Kaloz <kaloz@openwrt.org>2010-01-10 16:02:11 +0000
commit7d5f49afc1f9a2183a209c14e5fda43e6613a420 (patch)
treec6219b74180780f7f5a732779e3bafe899058de4 /target/linux/mpc83xx/image
parentf8a49928e5698a3d7126f6919a3d15821681d148 (diff)
downloadmaster-31e0f0ae-7d5f49afc1f9a2183a209c14e5fda43e6613a420.tar.gz
master-31e0f0ae-7d5f49afc1f9a2183a209c14e5fda43e6613a420.tar.bz2
master-31e0f0ae-7d5f49afc1f9a2183a209c14e5fda43e6613a420.zip
upgrade to 2.6.31, add preliminary support for the Freescale MPC8377E-WLAN board - not finished, yet
SVN-Revision: 19092
Diffstat (limited to 'target/linux/mpc83xx/image')
-rw-r--r--target/linux/mpc83xx/image/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/target/linux/mpc83xx/image/Makefile b/target/linux/mpc83xx/image/Makefile
index 1483786e8f..8004f746b5 100644
--- a/target/linux/mpc83xx/image/Makefile
+++ b/target/linux/mpc83xx/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,6 +9,7 @@ include $(INCLUDE_DIR)/image.mk
define Image/Prepare
+ $(LINUX_DIR)/scripts/dtc/dtc -O dtb -R 4 -S 0x20000 $(LINUX_DIR)/arch/powerpc/boot/dts/mpc8377_wlan.dts > $(KDIR)/openwrt-mpc8377_wlan.dtb
endef
define Image/BuildKernel
@@ -21,11 +22,12 @@ endef
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
- ( \
- dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \
- dd if=$(KDIR)/openwrt-canyonlands.dtb bs=128k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
- ) > $(BIN_DIR)/openwrt-$(BOARD)-canyonlands-$(1).img
+# We'll do FIT here
+# ( \
+# dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \
+# dd if=$(KDIR)/openwrt-mpc8377_wlan.dtb bs=128k conv=sync; \
+# dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
+# ) > $(BIN_DIR)/openwrt-$(BOARD)-mpc8377_wlan-$(1).img
endef
$(eval $(call BuildImage))