summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc83xx/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-11-09 11:45:04 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-11-09 11:45:04 +0000
commita992d6986c3004016f32f8be2524cd29ab4d0245 (patch)
tree304d9d09f6c06c4ede56271b17f969e7b5b93748 /target/linux/mpc83xx/image/Makefile
parentee937398f7919863625558d6a4b6a7fb5cee2186 (diff)
downloadmaster-31e0f0ae-a992d6986c3004016f32f8be2524cd29ab4d0245.tar.gz
master-31e0f0ae-a992d6986c3004016f32f8be2524cd29ab4d0245.tar.bz2
master-31e0f0ae-a992d6986c3004016f32f8be2524cd29ab4d0245.zip
add preliminary MPC83xx support
SVN-Revision: 18353
Diffstat (limited to 'target/linux/mpc83xx/image/Makefile')
-rw-r--r--target/linux/mpc83xx/image/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/mpc83xx/image/Makefile b/target/linux/mpc83xx/image/Makefile
new file mode 100644
index 0000000000..1483786e8f
--- /dev/null
+++ b/target/linux/mpc83xx/image/Makefile
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+
+define Image/Prepare
+endef
+
+define Image/BuildKernel
+ cp $(LINUX_DIR)/arch/powerpc/boot/dtbImage.rb600.elf $(BIN_DIR)/openwrt-$(BOARD)-rb600.elf
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \
+ dd if=$(KDIR)/openwrt-canyonlands.dtb bs=128k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-canyonlands-$(1).img
+endef
+
+$(eval $(call BuildImage))