summaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/profiles
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-11-02 10:18:50 +0000
committerJohn Crispin <john@openwrt.org>2015-11-02 10:18:50 +0000
commit25afe99b31f4ef3d835f96545e370770c230ac44 (patch)
tree5dbe83834a0a67121c557b7549a13221317f07eb /target/linux/mediatek/profiles
parent12e0d2737f558e886cf698e939f1758ab6a64947 (diff)
downloadmaster-31e0f0ae-25afe99b31f4ef3d835f96545e370770c230ac44.tar.gz
master-31e0f0ae-25afe99b31f4ef3d835f96545e370770c230ac44.tar.bz2
master-31e0f0ae-25afe99b31f4ef3d835f96545e370770c230ac44.zip
mediatek: add support for the new MT7623 Arm SoC
the support is still WIP. next steps are to make the pmic and ethernet work. this is the first commit to make sure nothing gets lost. Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 47354
Diffstat (limited to 'target/linux/mediatek/profiles')
-rw-r--r--target/linux/mediatek/profiles/default.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/mediatek/profiles/default.mk b/target/linux/mediatek/profiles/default.mk
new file mode 100644
index 0000000000..b83792aae0
--- /dev/null
+++ b/target/linux/mediatek/profiles/default.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile (minimum package set)
+ PACKAGES:= \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
+ kmod-usb3
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))