summaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2015-01-10 20:11:18 +0000
committerFlorian Fainelli <florian@openwrt.org>2015-01-10 20:11:18 +0000
commit3b523f6780113b0f55a2362ab093145dfa2a7c75 (patch)
treeb9e09c7b30333bc79e84ea280551fe9f55dfc244 /target/linux/mcs814x
parentd43997b2232abbefab5caca734bd91241346eeaf (diff)
downloadmaster-31e0f0ae-3b523f6780113b0f55a2362ab093145dfa2a7c75.tar.gz
master-31e0f0ae-3b523f6780113b0f55a2362ab093145dfa2a7c75.tar.bz2
master-31e0f0ae-3b523f6780113b0f55a2362ab093145dfa2a7c75.zip
mcs814x: account for dtb output directory differences
3.3 produced *.dtb files in arch/arm/boot/ while 3.14 will produce those in arch/arm/boot/dts/, adjust the image makefile accordingly. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 43925
Diffstat (limited to 'target/linux/mcs814x')
-rw-r--r--target/linux/mcs814x/image/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 1c814fa4fd..7f8722d6bd 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -9,6 +9,12 @@ include $(INCLUDE_DIR)/image.mk
TARGET_DTBS := rbt-832 dlan-usb-extender
+ifeq ($(KERNEL_PATCHVER),3.3)
+DTBS_DIR:=
+else
+DTBS_DIR:=dts/
+endif
+
LOADADDR:=0x00008000
JFFS2_BLOCKSIZE = 128k
@@ -22,7 +28,7 @@ endef
define Image/Build/DTB
cp $(KDIR)/zImage$(2) $(KDIR)/zImage-$(1);
- cat $(LINUX_DIR)/arch/$(ARCH)/boot/$(1).dtb >> $(KDIR)/zImage$(2)-$(1);
+ cat $(LINUX_DIR)/arch/$(ARCH)/boot/$(DTBS_DIR)$(1).dtb >> $(KDIR)/zImage$(2)-$(1);
$(call Image/Build/MkuImage,$(KDIR)/zImage$(2)-$(1),$(KDIR)/uImage$(2)-$(1))
cp $(KDIR)/uImage$(2)-$(1) $(UIMAGE)$(2)-$(1);
endef