summaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/profiles
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-09-03 20:25:40 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-09-03 20:25:40 +0000
commit1964753c22c81d83d2d8e5d8f0e361deb0a62647 (patch)
tree0b214f8fd17702da18144959d77a134ca339d428 /target/linux/mcs814x/profiles
parente88e20d9755e40c215f74ea5065af1fd3fd11a89 (diff)
downloadmaster-31e0f0ae-1964753c22c81d83d2d8e5d8f0e361deb0a62647.tar.gz
master-31e0f0ae-1964753c22c81d83d2d8e5d8f0e361deb0a62647.tar.bz2
master-31e0f0ae-1964753c22c81d83d2d8e5d8f0e361deb0a62647.zip
add Generic and dLAN USB Extender profiles
SVN-Revision: 33313
Diffstat (limited to 'target/linux/mcs814x/profiles')
-rw-r--r--target/linux/mcs814x/profiles/000-Generic.mk16
-rw-r--r--target/linux/mcs814x/profiles/100-dLAN-USB-Extender.mk17
2 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/mcs814x/profiles/000-Generic.mk b/target/linux/mcs814x/profiles/000-Generic.mk
new file mode 100644
index 0000000000..a6d0f30ec5
--- /dev/null
+++ b/target/linux/mcs814x/profiles/000-Generic.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic profile
+endef
+
+define Profile/Generic/Description
+ Default profile for Moschip MCS814x targets
+endef
+$(eval $(call Profile,Generic))
+
diff --git a/target/linux/mcs814x/profiles/100-dLAN-USB-Extender.mk b/target/linux/mcs814x/profiles/100-dLAN-USB-Extender.mk
new file mode 100644
index 0000000000..86aa5f8769
--- /dev/null
+++ b/target/linux/mcs814x/profiles/100-dLAN-USB-Extender.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/dLAN_USB_Extender
+ NAME:=Devolo dLAN USB Extender
+ PACKAGES:=hpavcfg foot
+endef
+
+define Profile/dLAN_USB_Extender/Description
+ Package set specifically tuned for the Devolo dLAN USB Extender device.
+endef
+$(eval $(call Profile,dLAN_USB_Extender))
+