summaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/patches-3.14/011-mcs814x_internal_phy.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2015-01-10 20:12:02 +0000
committerFlorian Fainelli <florian@openwrt.org>2015-01-10 20:12:02 +0000
commitdd4ee63fa43cf13190891a5df62676054942b52e (patch)
tree961871e70f77414e4bc647923a07119390b4676e /target/linux/mcs814x/patches-3.14/011-mcs814x_internal_phy.patch
parent3b523f6780113b0f55a2362ab093145dfa2a7c75 (diff)
downloadmaster-31e0f0ae-dd4ee63fa43cf13190891a5df62676054942b52e.tar.gz
master-31e0f0ae-dd4ee63fa43cf13190891a5df62676054942b52e.tar.bz2
master-31e0f0ae-dd4ee63fa43cf13190891a5df62676054942b52e.zip
mcs814x: add 3.14 kernel support
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 43926
Diffstat (limited to 'target/linux/mcs814x/patches-3.14/011-mcs814x_internal_phy.patch')
-rw-r--r--target/linux/mcs814x/patches-3.14/011-mcs814x_internal_phy.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/mcs814x/patches-3.14/011-mcs814x_internal_phy.patch b/target/linux/mcs814x/patches-3.14/011-mcs814x_internal_phy.patch
new file mode 100644
index 0000000000..9aeaf6e632
--- /dev/null
+++ b/target/linux/mcs814x/patches-3.14/011-mcs814x_internal_phy.patch
@@ -0,0 +1,20 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -157,6 +157,10 @@ config MICREL_PHY
+ ---help---
+ Currently has a driver for the KSZ8041
+
++config MCS814X_PHY
++ tristate "Driver for the Moschip MCS814x internal PHY"
++ depends on ARCH_MCS814X
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -49,3 +49,4 @@ obj-$(CONFIG_MDIO_BUS_MUX_GPIO) += mdio-
+ obj-$(CONFIG_MDIO_BUS_MUX_MMIOREG) += mdio-mux-mmioreg.o
+ obj-$(CONFIG_MDIO_SUN4I) += mdio-sun4i.o
+ obj-$(CONFIG_MDIO_MOXART) += mdio-moxart.o
++obj-$(CONFIG_MCS814X_PHY) += mcs814x.o