summaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-08-17 06:16:19 +0000
committerJohn Crispin <john@openwrt.org>2015-08-17 06:16:19 +0000
commitc0d0cb6d28f172e811a49701df62d174181bdba3 (patch)
treef2c637dd2dad63c113c9149e12d89492e31d3886 /target/linux/mcs814x/image
parentd8ec3ee77dcdda2daec796c6385ae3d22eb4b185 (diff)
downloadmaster-31e0f0ae-c0d0cb6d28f172e811a49701df62d174181bdba3.tar.gz
master-31e0f0ae-c0d0cb6d28f172e811a49701df62d174181bdba3.tar.bz2
master-31e0f0ae-c0d0cb6d28f172e811a49701df62d174181bdba3.zip
mcs814x: use firmware partition splitter on dLAN USB Extender
to avoid editing the dts every time the kernel size changes. uImage is now bigger than 1MB. Pad uImage to 64k erase block size. Signed-off-by: Günther Kelleter <guenther.kelleter@devolo.de> SVN-Revision: 46648
Diffstat (limited to 'target/linux/mcs814x/image')
-rw-r--r--target/linux/mcs814x/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 017a564f09..3afd660c14 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -31,7 +31,7 @@ define Image/Build/DTB
endef
define Image/Build/Profile/dLAN_USB_Extender
- dd if=$(KDIR)/uImage-dlan-usb-extender bs=1M conv=sync of=$(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
+ dd if=$(KDIR)/uImage-dlan-usb-extender bs=64k conv=sync of=$(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
cat $(KDIR)/root.$(1) >> $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
cp $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin $(BIN_DIR)/
endef