summaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-08-08 21:51:00 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-08-08 21:51:00 +0000
commit798cc28d73ab9da2c22ddccc77269a9fc2c7acbe (patch)
tree20ded37f63be32081da1a7ad0ab9abe5acf7c301 /target/linux/mcs814x/image
parentf8386ecbc681e9ecf52550bb1131dcacd8a15f84 (diff)
downloadmaster-31e0f0ae-798cc28d73ab9da2c22ddccc77269a9fc2c7acbe.tar.gz
master-31e0f0ae-798cc28d73ab9da2c22ddccc77269a9fc2c7acbe.tar.bz2
master-31e0f0ae-798cc28d73ab9da2c22ddccc77269a9fc2c7acbe.zip
build a Devolo dLAN USB Extender specific image
The kernel has to be rounded up to the nearest 1MB, then we append the root filesystem at its end. SVN-Revision: 33066
Diffstat (limited to 'target/linux/mcs814x/image')
-rw-r--r--target/linux/mcs814x/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 89772c98ef..f0642e3f9d 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -32,14 +32,21 @@ define Image/Prepare
cp $(LINUX_DIR)/arch/$(ARCH)/boot/zImage $(KDIR)/zImage
endef
+define Image/Build/dlan
+ dd if=$(KDIR)/uImage-dlan-usb-extender bs=1M conv=sync of=$(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade.bin
+ cat $(KDIR)/root.$(1) >> $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade.bin
+ cp $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade.bin $(BIN_DIR)/
+endef
+
define Image/BuildKernel
$(foreach dtb,$(TARGET_DTBS),$(call Image/Build/DTB,$(dtb)))
$(call Image/Build/Initramfs)
endef
define Image/Build
- $(call Image/Build/$(1))
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+ $(call Image/Build/$(1))
+ $(call Image/Build/dlan,$(1))
endef
$(eval $(call BuildImage))