summaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-09-03 20:25:46 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-09-03 20:25:46 +0000
commit19cbe80501688d31fb90c41c06e274e27fb449d1 (patch)
treef9728b063bf3056dfecb115cbab87384a69ecc72 /target/linux/mcs814x/image
parent1964753c22c81d83d2d8e5d8f0e361deb0a62647 (diff)
downloadmaster-31e0f0ae-19cbe80501688d31fb90c41c06e274e27fb449d1.tar.gz
master-31e0f0ae-19cbe80501688d31fb90c41c06e274e27fb449d1.tar.bz2
master-31e0f0ae-19cbe80501688d31fb90c41c06e274e27fb449d1.zip
pad squashfs image
SVN-Revision: 33314
Diffstat (limited to 'target/linux/mcs814x/image')
-rw-r--r--target/linux/mcs814x/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 5545e042e6..7386db0766 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -45,6 +45,10 @@ define Image/BuildKernel
$(call Image/Build/Initramfs)
endef
+define Image/Build/squashfs
+ $(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR)/root.squashfs 128
+endef
+
define Image/Build
$(call Image/Build/$(1))
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync