summaryrefslogtreecommitdiffstats
path: root/target/linux/malta/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-04-10 21:02:51 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-04-10 21:02:51 +0000
commitf4d71f5e8167a72e086dee9ab5f872240bdf2a17 (patch)
treeb8646a999e7cf167c15149611830ef48b69bf95e /target/linux/malta/image
parentb4d0b6cbb34d1cd5c71c122c2137e32476ec342a (diff)
downloadmaster-31e0f0ae-f4d71f5e8167a72e086dee9ab5f872240bdf2a17.tar.gz
master-31e0f0ae-f4d71f5e8167a72e086dee9ab5f872240bdf2a17.tar.bz2
master-31e0f0ae-f4d71f5e8167a72e086dee9ab5f872240bdf2a17.zip
create two endian-specific subtargets, as malta can run both
SVN-Revision: 20790
Diffstat (limited to 'target/linux/malta/image')
-rw-r--r--target/linux/malta/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/malta/image/Makefile b/target/linux/malta/image/Makefile
index 16e21a70c1..d203da2cbe 100644
--- a/target/linux/malta/image/Makefile
+++ b/target/linux/malta/image/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Image/BuildKernel
- cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(SUBTARGET)-vmlinux.elf
endef
define Image/Build/squashfs
@@ -17,7 +17,7 @@ endef
define Image/Build
$(call Image/Build/$(1))
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(SUBTARGET)-root.$(1) bs=128k conv=sync
endef
$(eval $(call BuildImage))