summaryrefslogtreecommitdiffstats
path: root/target/linux/malta/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-02-28 11:09:34 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-02-28 11:09:34 +0000
commit29011fe5161cf8bbb2addf876b17e9ebcb862a96 (patch)
treeec2333794bc0f352d85fc8eb105b1bdddccbda09 /target/linux/malta/image
parente34293297c3bdf32b43c83a2879b8510e6d5a009 (diff)
downloadmaster-31e0f0ae-29011fe5161cf8bbb2addf876b17e9ebcb862a96.tar.gz
master-31e0f0ae-29011fe5161cf8bbb2addf876b17e9ebcb862a96.tar.bz2
master-31e0f0ae-29011fe5161cf8bbb2addf876b17e9ebcb862a96.zip
add a MIPS Malta target to be used with qemu
SVN-Revision: 19893
Diffstat (limited to 'target/linux/malta/image')
-rw-r--r--target/linux/malta/image/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/malta/image/Makefile b/target/linux/malta/image/Makefile
new file mode 100644
index 0000000000..16e21a70c1
--- /dev/null
+++ b/target/linux/malta/image/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))