summaryrefslogtreecommitdiffstats
path: root/target/linux/magicbox/patches/100-cf_slot.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-08-01 19:34:37 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-08-01 19:34:37 +0000
commit014a020b5f7155cbac694de20f2dabbd442382d7 (patch)
tree0f5d6257e7982ba5be9ac587aaac19189fe8f8e4 /target/linux/magicbox/patches/100-cf_slot.patch
parent245c16ba5d30b745b103637d460463cdd270f50a (diff)
downloadmaster-31e0f0ae-014a020b5f7155cbac694de20f2dabbd442382d7.tar.gz
master-31e0f0ae-014a020b5f7155cbac694de20f2dabbd442382d7.tar.bz2
master-31e0f0ae-014a020b5f7155cbac694de20f2dabbd442382d7.zip
update to 2.6.26
SVN-Revision: 12066
Diffstat (limited to 'target/linux/magicbox/patches/100-cf_slot.patch')
-rw-r--r--target/linux/magicbox/patches/100-cf_slot.patch45
1 files changed, 14 insertions, 31 deletions
diff --git a/target/linux/magicbox/patches/100-cf_slot.patch b/target/linux/magicbox/patches/100-cf_slot.patch
index ca7ca4e621..e15d522df8 100644
--- a/target/linux/magicbox/patches/100-cf_slot.patch
+++ b/target/linux/magicbox/patches/100-cf_slot.patch
@@ -1,30 +1,18 @@
-Index: linux-2.6.24.7/drivers/ide/ide.c
-===================================================================
---- linux-2.6.24.7.orig/drivers/ide/ide.c
-+++ linux-2.6.24.7/drivers/ide/ide.c
-@@ -1563,6 +1563,7 @@ done:
- extern void __init pnpide_init(void);
- extern void __exit pnpide_exit(void);
- extern void __init h8300_ide_init(void);
-+extern void __init ide_magicbox_init(void);
+--- a/drivers/ide/ide.c
++++ b/drivers/ide/ide.c
+@@ -494,6 +494,9 @@
- /*
- * probe_for_hwifs() finds/initializes "known" IDE interfaces
-@@ -1627,6 +1628,9 @@ static void __init probe_for_hwifs (void
- #ifdef CONFIG_H8300
- h8300_ide_init();
+ return -EPERM;
#endif
+#ifdef CONFIG_BLK_DEV_MAGICBOX_IDE
+ ide_magicbox_init();
+#endif
}
- /*
-Index: linux-2.6.24.7/drivers/ide/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/ide/Kconfig
-+++ linux-2.6.24.7/drivers/ide/Kconfig
-@@ -1018,6 +1018,14 @@ config BLK_DEV_MPC8xx_IDE
+ int set_pio_mode(ide_drive_t *drive, int arg)
+--- a/drivers/ide/Kconfig
++++ b/drivers/ide/Kconfig
+@@ -928,6 +928,14 @@
If unsure, say N.
@@ -39,15 +27,10 @@ Index: linux-2.6.24.7/drivers/ide/Kconfig
choice
prompt "Type of MPC8xx IDE interface"
depends on BLK_DEV_MPC8xx_IDE
-Index: linux-2.6.24.7/drivers/ide/Makefile
-===================================================================
---- linux-2.6.24.7.orig/drivers/ide/Makefile
-+++ linux-2.6.24.7/drivers/ide/Makefile
-@@ -37,6 +37,7 @@ ide-core-$(CONFIG_BLK_DEV_Q40IDE) += leg
- # built-in only drivers from ppc/
- ide-core-$(CONFIG_BLK_DEV_MPC8xx_IDE) += ppc/mpc8xx.o
- ide-core-$(CONFIG_BLK_DEV_IDE_PMAC) += ppc/pmac.o
-+ide-core-$(CONFIG_BLK_DEV_MAGICBOX_IDE) += ppc/magicbox_ide.o
+--- a/drivers/ide/ppc/Makefile
++++ b/drivers/ide/ppc/Makefile
+@@ -1,3 +1,4 @@
- # built-in only drivers from h8300/
- ide-core-$(CONFIG_IDE_H8300) += h8300/ide-h8300.o
+ obj-$(CONFIG_BLK_DEV_IDE_PMAC) += pmac.o
+ obj-$(CONFIG_BLK_DEV_MPC8xx_IDE) += mpc8xx.o
++obj-$(CONFIG_BLK_DEV_MAGICBOX_IDE) += magicbox_ide.o