summaryrefslogtreecommitdiffstats
path: root/target/linux/magicbox-2.6
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
commit7a6a6464971c69fa1026aeaf8fad5c79250230e9 (patch)
treea68bcf07bd0d15b68d1b990877a55002585690b9 /target/linux/magicbox-2.6
parent927fb16abb41cfeeee4e97b4baed2d5ce036ca2e (diff)
downloadmaster-31e0f0ae-7a6a6464971c69fa1026aeaf8fad5c79250230e9.tar.gz
master-31e0f0ae-7a6a6464971c69fa1026aeaf8fad5c79250230e9.tar.bz2
master-31e0f0ae-7a6a6464971c69fa1026aeaf8fad5c79250230e9.zip
Add initial version of the new Image Builder It's still a bit rough in a few places, but it seems to work for Broadcom at least - other targets untested.
SVN-Revision: 6071
Diffstat (limited to 'target/linux/magicbox-2.6')
-rw-r--r--target/linux/magicbox-2.6/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/magicbox-2.6/image/Makefile b/target/linux/magicbox-2.6/image/Makefile
index 10f71df2a9..77ff88f521 100644
--- a/target/linux/magicbox-2.6/image/Makefile
+++ b/target/linux/magicbox-2.6/image/Makefile
@@ -11,10 +11,11 @@ define Build/Clean
endef
define Image/Prepare
+ cp $(LINUX_DIR)/arch/ppc/boot/images/uImage $(KDIR)/uImage
endef
define Image/BuildKernel
- cp $(LINUX_DIR)/arch/ppc/boot/images/uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
endef
define Image/Build
@@ -23,7 +24,7 @@ endef
define Image/Build/jffs2-64k
( \
- dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=65536 conv=sync; \
+ dd if=$(KDIR)/uImage bs=65536 conv=sync; \
dd if=$(KDIR)/root.$(1) bs=65536 conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
endef