summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-19 15:36:40 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-20 10:13:50 +0200
commitf12e9647336fd8aeb551dc589593e1773698f4ff (patch)
treef76ac60321ad48a94db0cf277044e5222fd3f1ef /target/linux/lantiq
parentbdfed2a2c33cc05a096b4f29e72a2a05f57918af (diff)
downloadmaster-31e0f0ae-f12e9647336fd8aeb551dc589593e1773698f4ff.tar.gz
master-31e0f0ae-f12e9647336fd8aeb551dc589593e1773698f4ff.tar.bz2
master-31e0f0ae-f12e9647336fd8aeb551dc589593e1773698f4ff.zip
lantiq: convert AVM xrx200 devices to new image build code
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/Makefile26
1 files changed, 16 insertions, 10 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index b5671d4a59..c6f18fc39e 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -35,6 +35,11 @@ define Image/BuildLoader/Template
compile loader.bin
endef
+define Build/eva-image
+ lzma2eva $(KERNEL_LOADADDR) $(KERNEL_LOADADDR) $@ $@.new
+ ( dd if=$@.new bs=64k conv=sync; cat ./eva.dummy.squashfs; ) > $@
+endef
+
define CompressLzma
$(STAGING_DIR_HOST)/bin/lzma e $(1) $(2)
@@ -235,6 +240,11 @@ define Device/lantiqFullImage
IMAGE/fullimage.img := fullimage | check-size $$$$(IMAGE_SIZE)
endef
+define Device/AVM
+ $(Device/NAND)
+ KERNEL := kernel-bin | append-dtb | lzma | eva-image
+endef
+
ifeq ($(SUBTARGET),xway_legacy)
define Device/ARV4520PW
@@ -627,23 +637,19 @@ define Device/EASY80920NOR
endef
TARGET_DEVICES += EASY80920NOR
-Image/BuildKernel/Profile/FRITZ3370=$(call Image/BuildKernelEVA/Template,FRITZ3370)
-Image/Build/Profile/FRITZ3370=$(call Image/BuildEVA/$(1),$(1),FRITZ3370)
-
-define LegacyDevice/FRITZ3370
+define Device/FRITZ3370
+ $(Device/AVM)
DEVICE_TITLE := Fritz!Box WLan - FRITZ3370
DEVICE_PACKAGES := kmod-ath9k wpad-mini kmod-usb-dwc2
endef
-LEGACY_DEVICES += FRITZ3370
-
-Image/BuildKernel/Profile/FRITZ7360SL=$(call Image/BuildKernelEVA/Template,FRITZ7360SL)
-Image/Build/Profile/FRITZ7360SL=$(call Image/BuildEVA/$(1),$(1),FRITZ7360SL)
+TARGET_DEVICES += FRITZ3370
-define LegacyDevice/FRITZ7360SL
+define Device/FRITZ7360SL
+ $(Device/AVM)
DEVICE_TITLE := 1&1 HomeServer - FRITZ7360SL
DEVICE_PACKAGES := kmod-ath9k wpad-mini kmod-usb-dwc2
endef
-LEGACY_DEVICES += FRITZ7360L
+TARGET_DEVICES += FRITZ7360SL
Image/Prepare/Profile/VG3503J=$(call Image/Prepare/Template,VG3503J)
Image/BuildKernel/Profile/VG3503J=$(call Image/BuildKernelLoader/Template,VG3503J)