summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-19 12:20:15 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-20 10:13:50 +0200
commitceee47ba646edd54c8b40365b43b4a048ef45cf5 (patch)
tree50285ed1e6910dff1ee1b5ec5eff44a8da5d0cc8 /target/linux/lantiq
parent1c1244193a7224e8e6430d3571a0a85c44ff0e61 (diff)
downloadmaster-31e0f0ae-ceee47ba646edd54c8b40365b43b4a048ef45cf5.tar.gz
master-31e0f0ae-ceee47ba646edd54c8b40365b43b4a048ef45cf5.tar.bz2
master-31e0f0ae-ceee47ba646edd54c8b40365b43b4a048ef45cf5.zip
lantiq: disable jffs2 support on xrx200
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/Makefile19
-rw-r--r--target/linux/lantiq/xrx200/target.mk2
2 files changed, 1 insertions, 20 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 95895c223b..5713faa11f 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -105,25 +105,6 @@ define Image/BuildLoader/squashfs
$(call prepare_generic_squashfs,$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image)
endef
-define Image/BuildEVA/jffs2-128k
- cat $(KDIR)/$(2).eva.align.128k $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image.eva
-endef
-
-define Image/Build/jffs2-64k
- dd if=$(KDIR)/uImage-$(2) of=$(KDIR)/uImage-$(2)-$(1) bs=64k conv=sync
- cat $(KDIR)/uImage-$(2)-$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image
-endef
-
-define Image/Build/jffs2-128k
- dd if=$(KDIR)/uImage-$(2) of=$(KDIR)/uImage-$(2)-$(1) bs=128k conv=sync
- cat $(KDIR)/uImage-$(2)-$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image
-endef
-
-define Image/Build/jffs2-256k
- dd if=$(KDIR)/uImage-$(2) of=$(KDIR)/uImage-$(2)-$(1) bs=256k conv=sync
- cat $(KDIR)/uImage-$(2)-$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image
-endef
-
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
define Image/BuildKernel/InitramfsTemplate
$(call PatchKernelLzma,$(1),-initramfs)
diff --git a/target/linux/lantiq/xrx200/target.mk b/target/linux/lantiq/xrx200/target.mk
index e112ea0996..6b8738c8a8 100644
--- a/target/linux/lantiq/xrx200/target.mk
+++ b/target/linux/lantiq/xrx200/target.mk
@@ -1,7 +1,7 @@
ARCH:=mips
SUBTARGET:=xrx200
BOARDNAME:=XRX200
-FEATURES:=squashfs atm mips16 jffs2 nand ubifs
+FEATURES:=squashfs atm mips16 nand ubifs
CPU_TYPE:=34kc
CPU_SUBTYPE:=dsp