summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorMartin Blumenstingl <martin.blumenstingl@googlemail.com>2016-08-21 17:01:33 +0200
committerJohn Crispin <john@phrozen.org>2016-08-22 07:43:11 +0200
commitc6164d961037ceb722b03ccfe1725be6b9a6d533 (patch)
treebe97b905a4d75d55e9743a793b2fa39de087a08e /target/linux/lantiq
parent00516611bd8324a2ab0781ad419e9ea11b3713f3 (diff)
downloadmaster-31e0f0ae-c6164d961037ceb722b03ccfe1725be6b9a6d533.tar.gz
master-31e0f0ae-c6164d961037ceb722b03ccfe1725be6b9a6d533.tar.bz2
master-31e0f0ae-c6164d961037ceb722b03ccfe1725be6b9a6d533.zip
lantiq: fix building AVM/EVA sysupgrade images on NOR devices
Device/AVM unconditionally inherits Device/NAND, which changes the sysupgrade image to sysupgrade-tar (instead of a "raw" sysupgrade image as used in the Device/Default template). This moves the Device/NAND call to the FRITZ3370 device definition, as this is the only AVM/EVA device that uses NAND. Additionally we have to define the IMAGE_SIZE for the AVM/EVA NOR devices to ensure that the images are not discarded. Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 3c3318d520..3c7391808d 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -219,7 +219,6 @@ define Device/lantiqFullImage
endef
define Device/AVM
- $(Device/NAND)
KERNEL := kernel-bin | append-dtb | lzma | eva-image
endef
@@ -523,6 +522,7 @@ TARGET_DEVICES += WBMRB
define Device/FRITZ7320
$(Device/AVM)
+ IMAGE_SIZE := 15744k
DEVICE_TITLE := 1&1 HomeServer - FRITZ7320
DEVICE_PACKAGES := kmod-ath9k wpad-mini \
kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
@@ -611,6 +611,7 @@ TARGET_DEVICES += EASY80920NOR
define Device/FRITZ3370
$(Device/AVM)
+ $(Device/NAND)
DEVICE_TITLE := Fritz!Box WLan - FRITZ3370
DEVICE_PACKAGES := kmod-ath9k wpad-mini kmod-usb-dwc2
endef
@@ -618,6 +619,7 @@ TARGET_DEVICES += FRITZ3370
define Device/FRITZ7360SL
$(Device/AVM)
+ IMAGE_SIZE := 15744k
DEVICE_TITLE := 1&1 HomeServer - FRITZ7360SL
DEVICE_PACKAGES := kmod-ath9k wpad-mini kmod-usb-dwc2
endef