summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-30 14:19:11 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-31 12:25:25 +0200
commit63b525dd6b209af5554a2d053efd4b3ce6f60c9c (patch)
treeb4bf688fa7ce3b9cbbad996dd0d60730eacbede9 /target/linux/lantiq
parent9201e88f518dbe5246aa2f77342175805ef10cdd (diff)
downloadmaster-31e0f0ae-63b525dd6b209af5554a2d053efd4b3ce6f60c9c.tar.gz
master-31e0f0ae-63b525dd6b209af5554a2d053efd4b3ce6f60c9c.tar.bz2
master-31e0f0ae-63b525dd6b209af5554a2d053efd4b3ce6f60c9c.zip
image: add a helper variable for getting kernel/rootfs from within image Build/* templates
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/Makefile8
-rw-r--r--target/linux/lantiq/image/tp-link.mk2
2 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 0718e9daea..f45da41dfc 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -152,21 +152,21 @@ define Build/mkbrncmdline
endef
define Build/mkbrnimg
- mkbrnimg -s $(SIGNATURE) -m $(MAGIC) -p $(CRC32_POLY) -o $@ $(word 1,$^) $(word 2,$^)
+ mkbrnimg -s $(SIGNATURE) -m $(MAGIC) -p $(CRC32_POLY) -o $@ $(IMAGE_KERNEL) $(IMAGE_ROOTFS)
endef
define Build/fullimage
mkimage -A mips -O linux -C lzma -T filesystem -a 0x00 \
-e 0x00 -n 'LEDE RootFS' \
- -d $(word 2,$^) $(word 2,$^).new
+ -d $(IMAGE_ROOTFS) $(IMAGE_ROOTFS).new
- cat $(word 1,$^) $(word 2,$^).new > $@.tmp
+ cat $(IMAGE_KERNEL) $(IMAGE_ROOTFS).new > $@.tmp
mkimage -A mips -O linux -T multi -a 0x00 -C none \
-e 0x00 -n 'OpenWrt fullimage' \
-d $@.tmp $@
- rm $(word 2,$^).new
+ rm $(IMAGE_ROOTFS).new
rm $@.tmp
endef
diff --git a/target/linux/lantiq/image/tp-link.mk b/target/linux/lantiq/image/tp-link.mk
index 554419185f..dbf0d6639f 100644
--- a/target/linux/lantiq/image/tp-link.mk
+++ b/target/linux/lantiq/image/tp-link.mk
@@ -6,7 +6,7 @@ endef
define Build/mktplinkfw2
mktplinkfw2 -B $(BOARD_ID) -s -a 0x4 -j \
- -k $(word 1,$^) -r $(word 2,$^) \
+ -k $(IMAGE_KERNEL) -r $(IMAGE_ROOTFS) \
-o $@
endef
DEVICE_VARS += BOARD_ID