summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-19 15:23:56 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-20 10:13:50 +0200
commit22c02060440d8930eb2f8f7fd510daa433694bd0 (patch)
treee6ca236fb866add5c9d8d33e84491ea72746ba7d /target/linux/lantiq
parent8058e4778bda5516a27facd3131c3d50d51efba0 (diff)
downloadmaster-31e0f0ae-22c02060440d8930eb2f8f7fd510daa433694bd0.tar.gz
master-31e0f0ae-22c02060440d8930eb2f8f7fd510daa433694bd0.tar.bz2
master-31e0f0ae-22c02060440d8930eb2f8f7fd510daa433694bd0.zip
lantiq: add image build template for NAND devices
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 788b275dec..da1ace9711 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -203,6 +203,25 @@ define Device/Default
endef
DEVICE_VARS += IMAGE_SIZE
+define Device/NAND/xway
+ BLOCKSIZE := 16KiB
+ PAGESIZE := 512
+ SUBPAGESIZE := 256
+ FILESYSTEMS += ubifs
+endef
+
+define Device/NAND/xrx200
+ BLOCKSIZE := 128KiB
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ FILESYSTEMS += ubifs
+endef
+
+define Device/NAND
+ $(Device/NAND/$(SUBTARGET))
+ IMAGE/sysupgrade.bin := sysupgrade-nand
+endef
+
define Device/lantiqBrnImage
KERNEL := kernel-bin | append-dtb | mkbrncmdline | lzma-no-dict
IMAGES := factory.bin