summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorBen Whitten <ben.whitten@lairdtech.com>2016-06-17 15:00:17 +0100
committerJohn Crispin <john@phrozen.org>2016-06-22 19:32:06 +0200
commitb7baaaf782f40bf6a1d017a1f41480b6229a12c9 (patch)
tree9b6969fd16d1ca63c61cdbfbe75a5bfeb1d25127 /target/linux/lantiq
parent7385f754b1a1562869ddf6a561f70623d626ed6b (diff)
downloadmaster-31e0f0ae-b7baaaf782f40bf6a1d017a1f41480b6229a12c9.tar.gz
master-31e0f0ae-b7baaaf782f40bf6a1d017a1f41480b6229a12c9.tar.bz2
master-31e0f0ae-b7baaaf782f40bf6a1d017a1f41480b6229a12c9.zip
kernel: Move append-dtb to common image-commands
This build step is used by various targets, move it to a common section. Signed-off-by: Ben Whitten <ben.whitten@gmail.com>
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index a54c3e212b..f76f6db790 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -174,11 +174,6 @@ endef
### Kernel scripts ###
-define Build/append-dtb
- $(call Image/BuildDTB,../dts/$(DEVICE_DTS).dts,$@.dtb)
- cat $@.dtb >> $@
-endef
-
define Build/mkbrncmdline
mkbrncmdline -i $@ -o $@.new BRN-BOOT
mv $@.new $@
@@ -213,11 +208,12 @@ define Device/Default
FILESYSTEMS := squashfs
DEVICE_PROFILE :=
DEVICE_DTS = $$(DEVICE_PROFILE)
+ DEVICE_DTS_DIR := ../dts
IMAGE_SIZE :=
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef
-DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS IMAGE_SIZE
+DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS DEVICE_DTS_DIR IMAGE_SIZE
define Device/lantiqBrnImage
KERNEL := kernel-bin | append-dtb | mkbrncmdline | lzma-no-dict