summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2016-05-30 11:54:05 +0200
committerJohn Crispin <john@phrozen.org>2016-06-05 23:23:57 +0200
commitaa930ba3ddccb8aa573b2e364d3f2315627d757f (patch)
tree0a38a3ce5db74df01a3388675bd5903aac8593bd /target/linux/lantiq
parent35c0328119d0d6cb2d710f998ca214dc4d7eeb59 (diff)
downloadmaster-31e0f0ae-aa930ba3ddccb8aa573b2e364d3f2315627d757f.tar.gz
master-31e0f0ae-aa930ba3ddccb8aa573b2e364d3f2315627d757f.tar.bz2
master-31e0f0ae-aa930ba3ddccb8aa573b2e364d3f2315627d757f.zip
lantiq: unmacro tp-link boards
even it's a little bit verbose, unmacrod board descriptions are much easier to read and to understand. Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/Makefile39
1 files changed, 25 insertions, 14 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index bdfd483d0f..f114007288 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -301,17 +301,6 @@ define Device/lantiqBrnImage
endef
DEVICE_VARS += SIGNATURE MAGIC CRC32_POLY
-define lantiqTpLink
- define Device/$(1)
- $$(Device/lantiqTpLink)
- DEVICE_PROFILE := $(1)
- DEVICE_DTS := $(1)
- IMAGE_SIZE := $(2)
- BOARD_ID := $(3)
- endef
- TARGET_DEVICES += $(1)
-endef
-
define lantiqImage
define Device/$(1)
$$(Device/lantiqImage)
@@ -439,9 +428,31 @@ Image/Build/Profile/FRITZ3370=$(call Image/BuildEVA/$(1),$(1),FRITZ3370)
Image/BuildKernel/Profile/VG3503J=$(call Image/BuildKernelLoader/Template,VG3503J)
Image/Build/Profile/VG3503J=$(call Image/BuildLoader/$(1),$(1),VG3503J)
-$(eval $(call lantiqTpLink,TDW8970,7680k,TD-W8970v1))
-$(eval $(call lantiqTpLink,TDW8980,7680k,TD-W8980v1))
-$(eval $(call lantiqTpLink,VR200v,15808k,ArcherVR200V))
+define Device/TDW8970
+ $(Device/lantiqTpLink)
+ DEVICE_PROFILE := TDW8970
+ DEVICE_DTS = $(DEVICE_PROFILE)
+ BOARD_ID := TD-W8970v1
+ IMAGE_SIZE := 7680k
+endef
+
+define Device/TDW8980
+ $(Device/lantiqTpLink)
+ DEVICE_PROFILE := TDW8980
+ DEVICE_DTS = $(DEVICE_PROFILE)
+ BOARD_ID := TD-W8980v1
+ IMAGE_SIZE := 7680k
+endef
+
+define Device/VR200v
+ $(Device/lantiqTpLink)
+ DEVICE_PROFILE := VR200v
+ DEVICE_DTS = $(DEVICE_PROFILE)
+ BOARD_ID := ArcherVR200V
+ IMAGE_SIZE := 15808k
+endef
+TARGET_DEVICES += TDW8970 TDW8980 VR200v
+
$(eval $(call lantiqImage,VGV7510KW22NOR,15232k))
$(eval $(call lantiqBrnImage,VGV7510KW22BRN,6784k,BRNDA6431,0x12345678,0x04c11db7))
$(eval $(call lantiqImage,VGV7519NOR,15360k))