summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-03-30 09:16:02 +0000
committerJohn Crispin <john@openwrt.org>2014-03-30 09:16:02 +0000
commit9b78e13aa3f8634e2ef33674691e4e5f252ee94f (patch)
tree9857f0005c564b5d9dffd4c6d267c6fedefe25d4 /target/linux/lantiq
parent2803e79be63f4f34474051c08954383a63e399fa (diff)
downloadmaster-31e0f0ae-9b78e13aa3f8634e2ef33674691e4e5f252ee94f.tar.gz
master-31e0f0ae-9b78e13aa3f8634e2ef33674691e4e5f252ee94f.tar.bz2
master-31e0f0ae-9b78e13aa3f8634e2ef33674691e4e5f252ee94f.zip
lantiq: add ubifs support in image Makefile
Signed-off-by: Antonios Vamporakis <ant@area128.com> SVN-Revision: 40316
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 094588868f..98f82369b1 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -118,6 +118,45 @@ define Image/Build/jffs2-256k
cat $(KDIR)/uImage-$(2)-$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image
endef
+define Image/Build/ubifs
+
+ifneq ($($(PROFILE)_UBIFS_OPTS),)
+ $(CP) $(KDIR)/root.ubifs $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-rootfs.ubifs
+endif
+endef
+
+define Image/Build/ubi
+
+ifneq ($($(PROFILE)_UBI_OPTS),)
+ $(CP) $(KDIR)/root.ubi $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-rootfs.ubi
+endif
+endef
+
+define Image/InstallKernel/Template
+
+ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
+ $(INSTALL_DIR) $(TARGET_DIR)/boot
+
+ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE),)
+ $(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-uImage $(TARGET_DIR)/boot/
+ ln -sf $(IMG_PREFIX)-$(1)-uImage $(TARGET_DIR)/boot/uImage
+endif
+
+ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_ZIMAGE),)
+ $(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-zImage $(TARGET_DIR)/boot/
+ ln -sf $(IMG_PREFIX)-$(1)-zImage $(TARGET_DIR)/boot/zImage
+endif
+endif
+
+ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
+ $(INSTALL_DIR) $(TARGET_DIR)/boot
+
+ifneq ($(1),)
+ $(CP) $(KDIR)/$(1).dtb $(TARGET_DIR)/boot/
+endif
+endif
+endef
+
define Image/BuildKernel/Template
$(call PatchKernelLzma,$(1))
$(call MkImageLzma,$(1))
@@ -307,6 +346,10 @@ define Image/BuildKernel
$(call Image/BuildKernel/Profile/$(PROFILE))
endef
+define Image/InstallKernel
+ $(call Image/InstallKernel/Template/$(PROFILE))
+endef
+
define Image/Build
$(call Image/Build/Profile/$(PROFILE),$(1))
endef