summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-06-17 18:50:07 +0200
committerFelix Fietkau <nbd@nbd.name>2016-06-17 20:11:24 +0200
commit9a0381f969f7eadc6d797ddcf397d0f5ca87d6a2 (patch)
tree1fad81bebcd8ea121fa5d918a38f251a0a6b9536 /target/linux/lantiq
parentff4a804669d45b24242bf3af3c062099a5a370e7 (diff)
downloadmaster-31e0f0ae-9a0381f969f7eadc6d797ddcf397d0f5ca87d6a2.tar.gz
master-31e0f0ae-9a0381f969f7eadc6d797ddcf397d0f5ca87d6a2.tar.bz2
master-31e0f0ae-9a0381f969f7eadc6d797ddcf397d0f5ca87d6a2.zip
lantiq: small fix for legacy profile builds
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/Makefile43
1 files changed, 7 insertions, 36 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 91a3a36917..9f3c8ecba8 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -175,31 +175,6 @@ endif
endef
-define Image/InstallKernel/Template
-
-ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
- $(INSTALL_DIR) $(TARGET_DIR)/boot
-
-ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE),)
- $(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-uImage $(TARGET_DIR)/boot/
- ln -sf $(IMG_PREFIX)-$(1)-uImage $(TARGET_DIR)/boot/uImage
-endif
-
-ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_ZIMAGE),)
- $(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-zImage $(TARGET_DIR)/boot/
- ln -sf $(IMG_PREFIX)-$(1)-zImage $(TARGET_DIR)/boot/zImage
-endif
-endif
-
-ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
- $(INSTALL_DIR) $(TARGET_DIR)/boot
-
-ifneq ($(1),)
- $(CP) $(KDIR)/$(1).dtb $(TARGET_DIR)/boot/
-endif
-endif
-endef
-
define Image/BuildKernel/Template
$(call PatchKernelLzma,$(1))
$(call MkImageLzma,$(1))
@@ -220,7 +195,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
endif
endef
-define Image/Prepare/Profile
+define Image/Prepare/Kernel
$(call PatchKernelLzma,$(1))
$(call Image/BuildLoader/Template,$(1))
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
@@ -793,6 +768,12 @@ define Device/VGV7519BRN
endef
TARGET_DEVICES += VGV7519BRN
+define Image/Prepare
+ $(call Image/Prepare/Kernel,VG3503J)
+endef
+
+endif
+
define Image/Prepare/Profile
$(call Image/Build/Profile/$(1),loader)
endef
@@ -802,20 +783,10 @@ define Image/Build/Profile
$(call Image/Build/Profile/$(1),$(2))
endef
-define Image/Prepare
- $(call Image/Prepare/Profile,VG3503J)
-endef
-
-endif
-
define Image/BuildKernel
$(call Image/BuildKernel/Profile/$(PROFILE))
endef
-define Image/InstallKernel
- $(call Image/InstallKernel/Template/$(PROFILE))
-endef
-
define Image/Build
$(call Image/Build/Profile/$(PROFILE),$(1))
endef