summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-03-14 18:43:34 +0000
committerJohn Crispin <john@openwrt.org>2013-03-14 18:43:34 +0000
commit5452dbad6163ded47be8f0c37aa7f725579cc323 (patch)
tree4f2b181d5fecb287426890508664dc4653df5d27 /target/linux/lantiq
parentc876ae5e0f1bfc8ec3231ae1229e30610e9a21dd (diff)
downloadmaster-31e0f0ae-5452dbad6163ded47be8f0c37aa7f725579cc323.tar.gz
master-31e0f0ae-5452dbad6163ded47be8f0c37aa7f725579cc323.tar.bz2
master-31e0f0ae-5452dbad6163ded47be8f0c37aa7f725579cc323.zip
build jffs images for nand based fritzbox
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 36026
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 067767fb36..45f9e142f5 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -70,6 +70,10 @@ define Image/BuildEVA/squashfs
$(call prepare_generic_squashfs,$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image.eva)
endef
+define Image/BuildNANDEVA/jffs2-128k
+ cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).rootfs
+endef
+
define Image/Build/jffs2-64k
dd if=$(KDIR)/uImage-$(2) of=$(KDIR)/uImage-$(2)-$(1) bs=64k conv=sync
cat $(KDIR)/uImage-$(2)-$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image
@@ -190,7 +194,7 @@ Image/BuildKernel/Profile/EASY80920NOR=$(call Image/BuildKernel/Template,EASY809
Image/Build/Profile/EASY80920NOR=$(call Image/Build/$(1),$(1),EASY80920NOR)
Image/BuildKernel/Profile/FRITZ3370=$(call Image/BuildKernelEVA/Template,FRITZ3370)
-Image/Build/Profile/FRITZ3370=$(call Image/BuildEVA/$(1),$(1),FRITZ3370)
+Image/Build/Profile/FRITZ3370=$(call Image/BuildNANDEVA/$(1),$(1),FRITZ3370)
endif