summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-09-17 21:46:00 +0000
committerJohn Crispin <john@openwrt.org>2013-09-17 21:46:00 +0000
commit18b76c66fbfea0e21ff66c6df432fa109c5bbb43 (patch)
tree2569112890e70dc5dcb8fdb2c0298bd58ba9f446 /target/linux/lantiq
parent2b0cb17d4298c9dced24ca30c5b68ce10d64c366 (diff)
downloadmaster-31e0f0ae-18b76c66fbfea0e21ff66c6df432fa109c5bbb43.tar.gz
master-31e0f0ae-18b76c66fbfea0e21ff66c6df432fa109c5bbb43.tar.bz2
master-31e0f0ae-18b76c66fbfea0e21ff66c6df432fa109c5bbb43.zip
lantiq: add a subtarget for the xrx200 SoC family
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 38029
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/Makefile2
-rw-r--r--target/linux/lantiq/image/Makefile4
-rw-r--r--target/linux/lantiq/image/ubinize.cfg14
-rw-r--r--target/linux/lantiq/xrx200/config-default43
-rw-r--r--target/linux/lantiq/xrx200/profiles/arv.mk7
-rw-r--r--target/linux/lantiq/xrx200/profiles/avm.mk10
-rw-r--r--target/linux/lantiq/xrx200/profiles/lantiq.mk21
-rw-r--r--target/linux/lantiq/xrx200/profiles/tplink.mk (renamed from target/linux/lantiq/xway/profiles/tplink.mk)0
-rw-r--r--target/linux/lantiq/xrx200/target.mk11
-rw-r--r--target/linux/lantiq/xway/config-default11
-rw-r--r--target/linux/lantiq/xway/profiles/arv.mk8
-rw-r--r--target/linux/lantiq/xway/profiles/avm.mk11
-rw-r--r--target/linux/lantiq/xway/profiles/lantiq.mk22
13 files changed, 121 insertions, 43 deletions
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index 94b506d4ee..4b820547fe 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
BOARD:=lantiq
BOARDNAME:=Lantiq GPON/XWAY/SVIP
FEATURES:=squashfs
-SUBTARGETS=xway ase falcon
+SUBTARGETS=xway xrx200 ase falcon
LINUX_VERSION:=3.8.13
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index e4e3e9e06b..fea32bef22 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -255,6 +255,10 @@ Image/Build/Profile/FRITZ7320=$(call Image/BuildEVA/$(1),$(1),FRITZ7320)
Image/BuildKernel/Profile/GR7000=$(call Image/BuildKernel/Template,GR7000)
Image/Build/Profile/GR7000=$(call Image/Build/$(1),$(1),GR7000)
+endif
+
+
+ifeq ($(CONFIG_TARGET_lantiq_xrx200),y)
# VR9
Image/BuildKernel/Profile/EASY80920NAND=$(call Image/BuildKernel/Template,EASY80920NAND)
diff --git a/target/linux/lantiq/image/ubinize.cfg b/target/linux/lantiq/image/ubinize.cfg
new file mode 100644
index 0000000000..49d55b9840
--- /dev/null
+++ b/target/linux/lantiq/image/ubinize.cfg
@@ -0,0 +1,14 @@
+[rootfs]
+# Volume mode (other option is static)
+mode=ubi
+# Source image
+image=root.ubifs
+# Volume ID in UBI image
+vol_id=0
+# Allow for dynamic resize
+vol_type=dynamic
+# Volume name
+vol_name=rootfs
+# Autoresize volume at first mount
+vol_flags=autoresize
+
diff --git a/target/linux/lantiq/xrx200/config-default b/target/linux/lantiq/xrx200/config-default
new file mode 100644
index 0000000000..d888b1ebb0
--- /dev/null
+++ b/target/linux/lantiq/xrx200/config-default
@@ -0,0 +1,43 @@
+CONFIG_ADM6996_PHY=y
+CONFIG_AR8216_PHY=y
+CONFIG_CLONE_BACKWARDS=y
+CONFIG_FIRMWARE_IN_KERNEL=y
+CONFIG_GPIO_DEVRES=y
+# CONFIG_HAVE_64BIT_ALIGNED_ACCESS is not set
+# CONFIG_HAVE_BOOTMEM_INFO_NODE is not set
+CONFIG_HAVE_KVM=y
+CONFIG_HZ_PERIODIC=y
+CONFIG_INPUT=y
+CONFIG_INPUT_EVDEV=y
+CONFIG_INPUT_POLLDEV=y
+CONFIG_IRQCHIP=y
+CONFIG_IRQ_WORK=y
+# CONFIG_ISDN is not set
+CONFIG_LEDS_TRIGGER_HEARTBEAT=y
+CONFIG_M25PXX_USE_FAST_READ=y
+CONFIG_MTD_M25P80=y
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_NAND_PLATFORM=y
+CONFIG_MTD_NAND_XWAY=y
+# CONFIG_MTD_PHYSMAP_OF is not set
+# CONFIG_MTD_SM_COMMON is not set
+CONFIG_NLS=y
+CONFIG_PCIE_LANTIQ=y
+# CONFIG_PCI_LANTIQ is not set
+# CONFIG_PROC_DEVICETREE is not set
+# CONFIG_RCU_STALL_COMMON is not set
+CONFIG_RTL8306_PHY=y
+CONFIG_RTL8366S_PHY=y
+CONFIG_RTL8367B_PHY=y
+CONFIG_RTL8367_PHY=y
+CONFIG_SPI=y
+CONFIG_SPI_BITBANG=y
+CONFIG_SPI_GPIO=y
+CONFIG_SPI_MASTER=y
+CONFIG_SPI_XWAY=y
+CONFIG_USB=y
+CONFIG_USB_COMMON=y
+# CONFIG_USB_EHCI_HCD is not set
+CONFIG_USB_SUPPORT=y
+# CONFIG_USB_UHCI_HCD is not set
diff --git a/target/linux/lantiq/xrx200/profiles/arv.mk b/target/linux/lantiq/xrx200/profiles/arv.mk
new file mode 100644
index 0000000000..ebb3fa880f
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/arv.mk
@@ -0,0 +1,7 @@
+define Profile/VG3503J
+ NAME:=BT Openreach - ECI VDSL Modem
+ PACKAGES:=kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+ kmod-ltq-ptm-vr9 ltq-vdsl-app
+endef
+
+$(eval $(call Profile,VG3503J))
diff --git a/target/linux/lantiq/xrx200/profiles/avm.mk b/target/linux/lantiq/xrx200/profiles/avm.mk
new file mode 100644
index 0000000000..77c1a0ad14
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/avm.mk
@@ -0,0 +1,10 @@
+define Profile/FRITZ3370
+ NAME:=Fritz!Box WLan - FRITZ3370
+ PACKAGES:=kmod-ath9k wpad-mini \
+ kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+ kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+ kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+ ltq-vdsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,FRITZ3370))
diff --git a/target/linux/lantiq/xrx200/profiles/lantiq.mk b/target/linux/lantiq/xrx200/profiles/lantiq.mk
new file mode 100644
index 0000000000..6380387e9a
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/lantiq.mk
@@ -0,0 +1,21 @@
+define Profile/EASY80920NOR
+ NAME:=Lantiq VR9 - EASY80920NOR
+ PACKAGES:=kmod-ath9k wpad-mini \
+ kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+ kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+ kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+ ltq-vdsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,EASY80920NOR))
+
+define Profile/EASY80920NAND
+ NAME:=Lantiq VR9 - EASY80920NAND
+ PACKAGES:=kmod-ath9k wpad-mini \
+ kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+ kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+ kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+ ltq-vdsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,EASY80920NAND))
diff --git a/target/linux/lantiq/xway/profiles/tplink.mk b/target/linux/lantiq/xrx200/profiles/tplink.mk
index fd4d76061f..fd4d76061f 100644
--- a/target/linux/lantiq/xway/profiles/tplink.mk
+++ b/target/linux/lantiq/xrx200/profiles/tplink.mk
diff --git a/target/linux/lantiq/xrx200/target.mk b/target/linux/lantiq/xrx200/target.mk
new file mode 100644
index 0000000000..0eb5937212
--- /dev/null
+++ b/target/linux/lantiq/xrx200/target.mk
@@ -0,0 +1,11 @@
+ARCH:=mips
+SUBTARGET:=xrx200
+BOARDNAME:=XRX200
+FEATURES:=squashfs atm mips16
+CFLAGS+= -mtune=34kc -mdsp
+
+DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug
+
+define Target/Description
+ Lantiq XRX200
+endef
diff --git a/target/linux/lantiq/xway/config-default b/target/linux/lantiq/xway/config-default
index 6ee3a3bc54..9feaa8e1c2 100644
--- a/target/linux/lantiq/xway/config-default
+++ b/target/linux/lantiq/xway/config-default
@@ -1,9 +1,17 @@
CONFIG_ADM6996_PHY=y
CONFIG_AR8216_PHY=y
+CONFIG_CLONE_BACKWARDS=y
CONFIG_FIRMWARE_IN_KERNEL=y
+CONFIG_GPIO_DEVRES=y
+# CONFIG_HAVE_64BIT_ALIGNED_ACCESS is not set
+# CONFIG_HAVE_BOOTMEM_INFO_NODE is not set
+CONFIG_HAVE_KVM=y
+CONFIG_HZ_PERIODIC=y
CONFIG_INPUT=y
CONFIG_INPUT_EVDEV=y
CONFIG_INPUT_POLLDEV=y
+CONFIG_IRQCHIP=y
+CONFIG_IRQ_WORK=y
# CONFIG_ISDN is not set
CONFIG_LEDS_TRIGGER_HEARTBEAT=y
CONFIG_M25PXX_USE_FAST_READ=y
@@ -13,9 +21,9 @@ CONFIG_MTD_NAND_ECC=y
CONFIG_MTD_NAND_PLATFORM=y
CONFIG_MTD_NAND_XWAY=y
# CONFIG_MTD_PHYSMAP_OF is not set
-# CONFIG_MTD_SM_COMMON is not set
CONFIG_NLS=y
# CONFIG_PROC_DEVICETREE is not set
+# CONFIG_RCU_STALL_COMMON is not set
CONFIG_RTL8306_PHY=y
CONFIG_RTL8366S_PHY=y
CONFIG_RTL8367B_PHY=y
@@ -30,3 +38,4 @@ CONFIG_USB_COMMON=y
# CONFIG_USB_EHCI_HCD is not set
CONFIG_USB_SUPPORT=y
# CONFIG_USB_UHCI_HCD is not set
+# CONFIG_XRX200_PHY_FW is not set
diff --git a/target/linux/lantiq/xway/profiles/arv.mk b/target/linux/lantiq/xway/profiles/arv.mk
index 4528741ea0..32bab8f643 100644
--- a/target/linux/lantiq/xway/profiles/arv.mk
+++ b/target/linux/lantiq/xway/profiles/arv.mk
@@ -125,11 +125,3 @@ define Profile/ARV752DPW22
endef
$(eval $(call Profile,ARV752DPW22))
-
-define Profile/VG3503J
- NAME:=BT Openreach - ECI VDSL Modem
- PACKAGES:=kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
- kmod-ltq-ptm-vr9 ltq-vdsl-app
-endef
-
-$(eval $(call Profile,VG3503J))
diff --git a/target/linux/lantiq/xway/profiles/avm.mk b/target/linux/lantiq/xway/profiles/avm.mk
index 8dba09dc85..1ca963b7cb 100644
--- a/target/linux/lantiq/xway/profiles/avm.mk
+++ b/target/linux/lantiq/xway/profiles/avm.mk
@@ -8,14 +8,3 @@ define Profile/FRITZ7320
endef
$(eval $(call Profile,FRITZ7320))
-
-define Profile/FRITZ3370
- NAME:=Fritz!Box WLan - FRITZ3370
- PACKAGES:=kmod-ath9k wpad-mini \
- kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
- kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
- kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
- ltq-vdsl-app ppp-mod-pppoa
-endef
-
-$(eval $(call Profile,FRITZ3370))
diff --git a/target/linux/lantiq/xway/profiles/lantiq.mk b/target/linux/lantiq/xway/profiles/lantiq.mk
index b4990b6604..800a9f6768 100644
--- a/target/linux/lantiq/xway/profiles/lantiq.mk
+++ b/target/linux/lantiq/xway/profiles/lantiq.mk
@@ -3,25 +3,3 @@ define Profile/EASY50712
endef
$(eval $(call Profile,EASY50712))
-
-define Profile/EASY80920NOR
- NAME:=Lantiq VR9 - EASY80920NOR
- PACKAGES:=kmod-ath9k wpad-mini \
- kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
- kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
- kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
- ltq-vdsl-app ppp-mod-pppoa
-endef
-
-$(eval $(call Profile,EASY80920NOR))
-
-define Profile/EASY80920NAND
- NAME:=Lantiq VR9 - EASY80920NAND
- PACKAGES:=kmod-ath9k wpad-mini \
- kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
- kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
- kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
- ltq-vdsl-app ppp-mod-pppoa
-endef
-
-$(eval $(call Profile,EASY80920NAND))