summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xway_legacy
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-06-13 19:04:20 +0200
committerJohn Crispin <john@phrozen.org>2016-06-13 22:51:43 +0200
commit239ad94165adc3ffb5290dd871d2ff0ddff4bdcf (patch)
tree03fcdeb281332b91774a3f261e58a2e822016116 /target/linux/lantiq/xway_legacy
parent2ae06f30134f856b7f27132dffe725817f4fb801 (diff)
downloadmaster-31e0f0ae-239ad94165adc3ffb5290dd871d2ff0ddff4bdcf.tar.gz
master-31e0f0ae-239ad94165adc3ffb5290dd871d2ff0ddff4bdcf.tar.bz2
master-31e0f0ae-239ad94165adc3ffb5290dd871d2ff0ddff4bdcf.zip
lantiq: add xway_legacy target
due to bloat recent builds fail to fit into the flash of the old danube units Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/lantiq/xway_legacy')
-rw-r--r--target/linux/lantiq/xway_legacy/config-default29
-rw-r--r--target/linux/lantiq/xway_legacy/profiles/00-default.mk9
-rw-r--r--target/linux/lantiq/xway_legacy/target.mk12
3 files changed, 50 insertions, 0 deletions
diff --git a/target/linux/lantiq/xway_legacy/config-default b/target/linux/lantiq/xway_legacy/config-default
new file mode 100644
index 0000000000..b838106ddc
--- /dev/null
+++ b/target/linux/lantiq/xway_legacy/config-default
@@ -0,0 +1,29 @@
+CONFIG_ADM6996_PHY=y
+CONFIG_AR8216_PHY=y
+CONFIG_CRC16=y
+CONFIG_CRYPTO_DEFLATE=y
+CONFIG_CRYPTO_LZO=y
+CONFIG_FIRMWARE_IN_KERNEL=y
+# CONFIG_GPIO_SYSFS is not set
+# CONFIG_HW_RANDOM is not set
+CONFIG_INPUT=y
+CONFIG_INPUT_EVDEV=y
+CONFIG_INPUT_POLLDEV=y
+# CONFIG_ISDN is not set
+CONFIG_LEDS_TRIGGER_HEARTBEAT=y
+# CONFIG_LEDS_TRIGGER_TIMER is not set
+CONFIG_LZO_COMPRESS=y
+CONFIG_LZO_DECOMPRESS=y
+# CONFIG_MTD_PHYSMAP_OF is not set
+CONFIG_NLS=y
+CONFIG_RTL8306_PHY=y
+CONFIG_RTL8366S_PHY=y
+CONFIG_RTL8367B_PHY=y
+CONFIG_RTL8367_PHY=y
+CONFIG_USB=y
+CONFIG_USB_COMMON=y
+# CONFIG_USB_EHCI_HCD is not set
+CONFIG_USB_SUPPORT=y
+# CONFIG_USB_UHCI_HCD is not set
+CONFIG_ZLIB_DEFLATE=y
+CONFIG_ZLIB_INFLATE=y
diff --git a/target/linux/lantiq/xway_legacy/profiles/00-default.mk b/target/linux/lantiq/xway_legacy/profiles/00-default.mk
new file mode 100644
index 0000000000..26bc8b502b
--- /dev/null
+++ b/target/linux/lantiq/xway_legacy/profiles/00-default.mk
@@ -0,0 +1,9 @@
+define Profile/Default
+ NAME:=Default Profile
+ PRIORITY:=1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/lantiq/xway_legacy/target.mk b/target/linux/lantiq/xway_legacy/target.mk
new file mode 100644
index 0000000000..2d9cc56d38
--- /dev/null
+++ b/target/linux/lantiq/xway_legacy/target.mk
@@ -0,0 +1,12 @@
+ARCH:=mips
+SUBTARGET:=xway_legacy
+BOARDNAME:=XWAY Legacy
+FEATURES:=squashfs atm mips16 ramdisk small_flash
+CPU_TYPE:=34kc
+CPU_SUBTYPE:=dsp
+
+DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug
+
+define Target/Description
+ Lantiq XWAY Legacy for old boards with small flash
+endef