summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xway
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-03-30 09:16:15 +0000
committerJohn Crispin <john@openwrt.org>2014-03-30 09:16:15 +0000
commite733242a2399fb444997a6c10f45f15d2166c872 (patch)
tree7d979804de23b36d5b5807902ea782e267956a84 /target/linux/lantiq/xway
parent3a43738e214a256dbe59f17796ddb967b08ee67c (diff)
downloadmaster-31e0f0ae-e733242a2399fb444997a6c10f45f15d2166c872.tar.gz
master-31e0f0ae-e733242a2399fb444997a6c10f45f15d2166c872.tar.bz2
master-31e0f0ae-e733242a2399fb444997a6c10f45f15d2166c872.zip
lantiq: add support for Arcadyan ARV7519PW
This patch adds almost full support for this board. - WiFi is still not working - USB will not power up. According to some reports, it may be a passive port Signed-off-by: Antonios Vamporakis <ant@area128.com> SVN-Revision: 40319
Diffstat (limited to 'target/linux/lantiq/xway')
-rw-r--r--target/linux/lantiq/xway/profiles/arv.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/lantiq/xway/profiles/arv.mk b/target/linux/lantiq/xway/profiles/arv.mk
index 9b172f266e..30cc7780bb 100644
--- a/target/linux/lantiq/xway/profiles/arv.mk
+++ b/target/linux/lantiq/xway/profiles/arv.mk
@@ -92,6 +92,18 @@ endef
$(eval $(call Profile,ARV7518PW))
+define Profile/ARV7519PW
+ NAME:=Astoria - ARV7519PW
+ PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-a kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-rt2800-pci wpad-mini \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV7519PW))
+
define Profile/ARV4520PW
NAME:=Easybox 800, WAV-281 - ARV4520PW
PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \