summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xway
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-01-28 17:42:59 +0000
committerJohn Crispin <john@openwrt.org>2013-01-28 17:42:59 +0000
commit5eb43d4cf8451c965f92d56cf717918098e03321 (patch)
tree373dc9453cc27308335a0493fc10a7e198342def /target/linux/lantiq/xway
parent509f39a10a4295c85d2a6f63573bb0698a067241 (diff)
downloadmaster-31e0f0ae-5eb43d4cf8451c965f92d56cf717918098e03321.tar.gz
master-31e0f0ae-5eb43d4cf8451c965f92d56cf717918098e03321.tar.bz2
master-31e0f0ae-5eb43d4cf8451c965f92d56cf717918098e03321.zip
Add support for ARV4518PW R01 and rename R01A.
There are two different versions of SMC7908A-ISP: R01 and R01A. R01 has an internal clock for PCI, meanwhile R01A has an external clock. This fixes: https://dev.openwrt.org/ticket/12884 Signed-off-by: John Crispin <blogic@openwrt.org> Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 35352
Diffstat (limited to 'target/linux/lantiq/xway')
-rw-r--r--target/linux/lantiq/xway/profiles/arv.mk18
1 files changed, 15 insertions, 3 deletions
diff --git a/target/linux/lantiq/xway/profiles/arv.mk b/target/linux/lantiq/xway/profiles/arv.mk
index c0c7c7c810..a4f11ca238 100644
--- a/target/linux/lantiq/xway/profiles/arv.mk
+++ b/target/linux/lantiq/xway/profiles/arv.mk
@@ -18,8 +18,8 @@ endef
$(eval $(call Profile,ARV7525PW))
-define Profile/ARV4518PW
- NAME:=SMC7908A-ISP, Airties WAV-221 - ARV4518PW
+define Profile/ARV4518PWR01
+ NAME:=ARV4518PWR01
PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
@@ -28,7 +28,19 @@ define Profile/ARV4518PW
swconfig
endef
-$(eval $(call Profile,ARV4518PW))
+$(eval $(call Profile,ARV4518PWR01))
+
+define Profile/ARV4518PWR01A
+ NAME:=ARV4518PWR01A
+ PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ath5k wpad-mini \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV4518PWR01A))
define Profile/ARV4510PW
NAME:=Wippies Homebox - ARV4510PW