summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xway
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-09-17 21:46:00 +0000
committerJohn Crispin <john@openwrt.org>2013-09-17 21:46:00 +0000
commit18b76c66fbfea0e21ff66c6df432fa109c5bbb43 (patch)
tree2569112890e70dc5dcb8fdb2c0298bd58ba9f446 /target/linux/lantiq/xway
parent2b0cb17d4298c9dced24ca30c5b68ce10d64c366 (diff)
downloadmaster-31e0f0ae-18b76c66fbfea0e21ff66c6df432fa109c5bbb43.tar.gz
master-31e0f0ae-18b76c66fbfea0e21ff66c6df432fa109c5bbb43.tar.bz2
master-31e0f0ae-18b76c66fbfea0e21ff66c6df432fa109c5bbb43.zip
lantiq: add a subtarget for the xrx200 SoC family
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 38029
Diffstat (limited to 'target/linux/lantiq/xway')
-rw-r--r--target/linux/lantiq/xway/config-default11
-rw-r--r--target/linux/lantiq/xway/profiles/arv.mk8
-rw-r--r--target/linux/lantiq/xway/profiles/avm.mk11
-rw-r--r--target/linux/lantiq/xway/profiles/lantiq.mk22
-rw-r--r--target/linux/lantiq/xway/profiles/tplink.mk11
5 files changed, 10 insertions, 53 deletions
diff --git a/target/linux/lantiq/xway/config-default b/target/linux/lantiq/xway/config-default
index 6ee3a3bc54..9feaa8e1c2 100644
--- a/target/linux/lantiq/xway/config-default
+++ b/target/linux/lantiq/xway/config-default
@@ -1,9 +1,17 @@
CONFIG_ADM6996_PHY=y
CONFIG_AR8216_PHY=y
+CONFIG_CLONE_BACKWARDS=y
CONFIG_FIRMWARE_IN_KERNEL=y
+CONFIG_GPIO_DEVRES=y
+# CONFIG_HAVE_64BIT_ALIGNED_ACCESS is not set
+# CONFIG_HAVE_BOOTMEM_INFO_NODE is not set
+CONFIG_HAVE_KVM=y
+CONFIG_HZ_PERIODIC=y
CONFIG_INPUT=y
CONFIG_INPUT_EVDEV=y
CONFIG_INPUT_POLLDEV=y
+CONFIG_IRQCHIP=y
+CONFIG_IRQ_WORK=y
# CONFIG_ISDN is not set
CONFIG_LEDS_TRIGGER_HEARTBEAT=y
CONFIG_M25PXX_USE_FAST_READ=y
@@ -13,9 +21,9 @@ CONFIG_MTD_NAND_ECC=y
CONFIG_MTD_NAND_PLATFORM=y
CONFIG_MTD_NAND_XWAY=y
# CONFIG_MTD_PHYSMAP_OF is not set
-# CONFIG_MTD_SM_COMMON is not set
CONFIG_NLS=y
# CONFIG_PROC_DEVICETREE is not set
+# CONFIG_RCU_STALL_COMMON is not set
CONFIG_RTL8306_PHY=y
CONFIG_RTL8366S_PHY=y
CONFIG_RTL8367B_PHY=y
@@ -30,3 +38,4 @@ CONFIG_USB_COMMON=y
# CONFIG_USB_EHCI_HCD is not set
CONFIG_USB_SUPPORT=y
# CONFIG_USB_UHCI_HCD is not set
+# CONFIG_XRX200_PHY_FW is not set
diff --git a/target/linux/lantiq/xway/profiles/arv.mk b/target/linux/lantiq/xway/profiles/arv.mk
index 4528741ea0..32bab8f643 100644
--- a/target/linux/lantiq/xway/profiles/arv.mk
+++ b/target/linux/lantiq/xway/profiles/arv.mk
@@ -125,11 +125,3 @@ define Profile/ARV752DPW22
endef
$(eval $(call Profile,ARV752DPW22))
-
-define Profile/VG3503J
- NAME:=BT Openreach - ECI VDSL Modem
- PACKAGES:=kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
- kmod-ltq-ptm-vr9 ltq-vdsl-app
-endef
-
-$(eval $(call Profile,VG3503J))
diff --git a/target/linux/lantiq/xway/profiles/avm.mk b/target/linux/lantiq/xway/profiles/avm.mk
index 8dba09dc85..1ca963b7cb 100644
--- a/target/linux/lantiq/xway/profiles/avm.mk
+++ b/target/linux/lantiq/xway/profiles/avm.mk
@@ -8,14 +8,3 @@ define Profile/FRITZ7320
endef
$(eval $(call Profile,FRITZ7320))
-
-define Profile/FRITZ3370
- NAME:=Fritz!Box WLan - FRITZ3370
- PACKAGES:=kmod-ath9k wpad-mini \
- kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
- kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
- kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
- ltq-vdsl-app ppp-mod-pppoa
-endef
-
-$(eval $(call Profile,FRITZ3370))
diff --git a/target/linux/lantiq/xway/profiles/lantiq.mk b/target/linux/lantiq/xway/profiles/lantiq.mk
index b4990b6604..800a9f6768 100644
--- a/target/linux/lantiq/xway/profiles/lantiq.mk
+++ b/target/linux/lantiq/xway/profiles/lantiq.mk
@@ -3,25 +3,3 @@ define Profile/EASY50712
endef
$(eval $(call Profile,EASY50712))
-
-define Profile/EASY80920NOR
- NAME:=Lantiq VR9 - EASY80920NOR
- PACKAGES:=kmod-ath9k wpad-mini \
- kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
- kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
- kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
- ltq-vdsl-app ppp-mod-pppoa
-endef
-
-$(eval $(call Profile,EASY80920NOR))
-
-define Profile/EASY80920NAND
- NAME:=Lantiq VR9 - EASY80920NAND
- PACKAGES:=kmod-ath9k wpad-mini \
- kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
- kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
- kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
- ltq-vdsl-app ppp-mod-pppoa
-endef
-
-$(eval $(call Profile,EASY80920NAND))
diff --git a/target/linux/lantiq/xway/profiles/tplink.mk b/target/linux/lantiq/xway/profiles/tplink.mk
deleted file mode 100644
index fd4d76061f..0000000000
--- a/target/linux/lantiq/xway/profiles/tplink.mk
+++ /dev/null
@@ -1,11 +0,0 @@
-define Profile/TDW8970
- NAME:=TP-LINK TD-W8970
- PACKAGES:=kmod-ath9k wpad-mini \
- kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
- kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
- kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
- ltq-vdsl-app ppp-mod-pppoa \
- kmod-ledtrig-usbdev
-endef
-
-$(eval $(call Profile,TDW8970))