summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xway/profiles
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-02-01 14:37:35 +0000
committerJohn Crispin <john@openwrt.org>2011-02-01 14:37:35 +0000
commit1e89df511a1506c0d476466f7cb60950522e51e3 (patch)
tree9030ad26ad3d83cda1743b31ce16add02d240f47 /target/linux/lantiq/xway/profiles
parente919bd002a7f08d1c893dc3272f1f6332442fc35 (diff)
downloadmaster-31e0f0ae-1e89df511a1506c0d476466f7cb60950522e51e3.tar.gz
master-31e0f0ae-1e89df511a1506c0d476466f7cb60950522e51e3.tar.bz2
master-31e0f0ae-1e89df511a1506c0d476466f7cb60950522e51e3.zip
* adds profiles to the kernel * fixes 2 compile errors in the usb driver * ioports were not allocated properly
SVN-Revision: 25278
Diffstat (limited to 'target/linux/lantiq/xway/profiles')
-rw-r--r--target/linux/lantiq/xway/profiles/000-generic.mk6
-rw-r--r--target/linux/lantiq/xway/profiles/001-lantiq.mk22
-rw-r--r--target/linux/lantiq/xway/profiles/002-arcadyan.mk13
3 files changed, 41 insertions, 0 deletions
diff --git a/target/linux/lantiq/xway/profiles/000-generic.mk b/target/linux/lantiq/xway/profiles/000-generic.mk
new file mode 100644
index 0000000000..787a74fba2
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/000-generic.mk
@@ -0,0 +1,6 @@
+define Profile/Generic
+ NAME:=Generic - all boards
+ PACKAGES:=kmod-leds-gpio button-hotplug
+endef
+
+$(eval $(call Profile,Generic))
diff --git a/target/linux/lantiq/xway/profiles/001-lantiq.mk b/target/linux/lantiq/xway/profiles/001-lantiq.mk
new file mode 100644
index 0000000000..cf1c559b6b
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/001-lantiq.mk
@@ -0,0 +1,22 @@
+define Profile/EASY50712
+ NAME:=EASY50712
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-leds-gpio
+endef
+
+define Profile/EASY50712/Description
+ Lantiq EASY50712 evalkit
+endef
+
+$(eval $(call Profile,EASY50712))
+
+define Profile/EASY50812
+ NAME:=EASY50812
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-leds-gpio
+endef
+
+define Profile/EASY50812/Description
+ Lantiq EASY50812 evalkit
+endef
+
+$(eval $(call Profile,EASY50812))
+
diff --git a/target/linux/lantiq/xway/profiles/002-arcadyan.mk b/target/linux/lantiq/xway/profiles/002-arcadyan.mk
new file mode 100644
index 0000000000..5575766f19
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/002-arcadyan.mk
@@ -0,0 +1,13 @@
+define Profile/ARV752DPW22
+ NAME:=ARV752DPW22 - Arcor Easybox 803
+ PACKAGES:= kmod-usb-core kmod-usb2 kmod-usb-uhci kmod-usb-dwc-otg \
+ kmod-ledtrig-netdev kmod-ledtrig-usbdev kmod-leds-gpio kmod-button-hotplug \
+ ltq-dsl-firmware-b
+endef
+
+define Profile/ARV752DPW22/Description
+ Package set optimized for the ARV752PW22
+endef
+
+$(eval $(call Profile,ARV752DPW22))
+