summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xrx200
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-03-30 10:02:30 +0000
committerJohn Crispin <john@openwrt.org>2014-03-30 10:02:30 +0000
commite36568e74b406f5c718904b330fcc7cb34ab2a17 (patch)
tree7b0a91eb996ecdf02e3a8e07d6ec558ea3b12970 /target/linux/lantiq/xrx200
parent42e8cb6388a7f9bfd8ff820a5af9193e8fb67fa8 (diff)
downloadmaster-31e0f0ae-e36568e74b406f5c718904b330fcc7cb34ab2a17.tar.gz
master-31e0f0ae-e36568e74b406f5c718904b330fcc7cb34ab2a17.tar.bz2
master-31e0f0ae-e36568e74b406f5c718904b330fcc7cb34ab2a17.zip
lntiq: add support for Astoria ARV7519RW.
These patches add support for the Astoria ARV7519RW aka Livebox 2.1 The PCI and PCIe interfaces have been disabled. Also, because there are two revisions of this board with different GPHY firmwares, two targets were defined. V2: rewrote partitions to work with an u-boot specifically made for these boards. Signed off by: Esteban Benito <estebanjbs@gmail.com> Signed off by: Carles Gadea <carlesgrg@gmail.com> Tested by: José Vázquez Fernández <ppvazquezfer@gmail.com> SVN-Revision: 40329
Diffstat (limited to 'target/linux/lantiq/xrx200')
-rw-r--r--target/linux/lantiq/xrx200/profiles/arv.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/lantiq/xrx200/profiles/arv.mk b/target/linux/lantiq/xrx200/profiles/arv.mk
index 317297134d..ce6f761001 100644
--- a/target/linux/lantiq/xrx200/profiles/arv.mk
+++ b/target/linux/lantiq/xrx200/profiles/arv.mk
@@ -27,3 +27,25 @@ define Profile/VGV7519BRN
endef
$(eval $(call Profile,VGV7519BRN))
+
+define Profile/ARV7519RWV11
+ NAME:=Livebox Astoria V1
+ PACKAGES:=kmod-ath9k wpad-mini \
+ kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+ kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+ kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+ ltq-vdsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,ARV7519RWV11))
+
+define Profile/ARV7519RWV12
+ NAME:=Livebox Astoria V2
+ PACKAGES:=kmod-ath9k wpad-mini \
+ kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+ kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+ kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+ ltq-vdsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,ARV7519RWV12))