summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xrx200
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-03-30 09:16:06 +0000
committerJohn Crispin <john@openwrt.org>2014-03-30 09:16:06 +0000
commit9531390aadea49eff8d173c79787670daa97762f (patch)
tree8f9c7f2b2ac0bfcd0d83206317c88d95a8e5a1ec /target/linux/lantiq/xrx200
parent9b78e13aa3f8634e2ef33674691e4e5f252ee94f (diff)
downloadmaster-31e0f0ae-9531390aadea49eff8d173c79787670daa97762f.tar.gz
master-31e0f0ae-9531390aadea49eff8d173c79787670daa97762f.tar.bz2
master-31e0f0ae-9531390aadea49eff8d173c79787670daa97762f.zip
lantiq: add support for ZyXEL P2812HNUFX
This patch adds almost full support for this board. WiFi is still not working. The FXS ports are not functional due to missing support for the TAPI driver on VR9 SoC. Signed-off-by: Antonios Vamporakis <ant@area128.com> Tested-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 40317
Diffstat (limited to 'target/linux/lantiq/xrx200')
-rw-r--r--target/linux/lantiq/xrx200/profiles/zyxel.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/lantiq/xrx200/profiles/zyxel.mk b/target/linux/lantiq/xrx200/profiles/zyxel.mk
new file mode 100644
index 0000000000..e758a50360
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/zyxel.mk
@@ -0,0 +1,14 @@
+define Profile/P2812HNUFX
+ NAME:=ZyXEL P-2812HNU-Fx
+ PACKAGES:=kmod-rt2800-pci wpad-mini \
+ kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+ kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+ kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+ ltq-vdsl-app ppp-mod-pppoa \
+ swconfig
+endef
+
+P2812HNUFX_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+P2812HNUFX_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,P2812HNUFX))