summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xrx200
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-01-17 07:07:15 +0000
committerJohn Crispin <john@openwrt.org>2015-01-17 07:07:15 +0000
commit7f77870c19218b65d4262e329b1736ababb9e384 (patch)
tree44e057c607c69727ef82e87d4f3b440ca15ba20f /target/linux/lantiq/xrx200
parentb4d2b69c43b032f8b8ef07fc1d9dcbb80d23556d (diff)
downloadmaster-31e0f0ae-7f77870c19218b65d4262e329b1736ababb9e384.tar.gz
master-31e0f0ae-7f77870c19218b65d4262e329b1736ababb9e384.tar.bz2
master-31e0f0ae-7f77870c19218b65d4262e329b1736ababb9e384.zip
Add profile and userspace for P2812HNUF1/3, switch from UBI_GLUEBI to UBI_BLOCK
Add profile and userspace for P2812HNUF1/3, switch from UBI_GLUEBI to UBI_BLOCK Signed-off-by: Sylwester Petela <sscapi@gmail.com> SVN-Revision: 43987
Diffstat (limited to 'target/linux/lantiq/xrx200')
-rw-r--r--target/linux/lantiq/xrx200/config-default4
-rw-r--r--target/linux/lantiq/xrx200/profiles/zyxel.mk26
2 files changed, 23 insertions, 7 deletions
diff --git a/target/linux/lantiq/xrx200/config-default b/target/linux/lantiq/xrx200/config-default
index 09dfbdd2a0..73dad50240 100644
--- a/target/linux/lantiq/xrx200/config-default
+++ b/target/linux/lantiq/xrx200/config-default
@@ -30,9 +30,9 @@ CONFIG_MTD_NAND_XWAY=y
# CONFIG_MTD_SM_COMMON is not set
CONFIG_MTD_UBI=y
CONFIG_MTD_UBI_BEB_LIMIT=20
-# CONFIG_MTD_UBI_BLOCK is not set
+CONFIG_MTD_UBI_BLOCK=y
# CONFIG_MTD_UBI_FASTMAP is not set
-CONFIG_MTD_UBI_GLUEBI=y
+# CONFIG_MTD_UBI_GLUEBI is not set
CONFIG_MTD_UBI_WL_THRESHOLD=4096
CONFIG_NLS=y
CONFIG_PCIE_LANTIQ=y
diff --git a/target/linux/lantiq/xrx200/profiles/zyxel.mk b/target/linux/lantiq/xrx200/profiles/zyxel.mk
index e758a50360..a43ee1433d 100644
--- a/target/linux/lantiq/xrx200/profiles/zyxel.mk
+++ b/target/linux/lantiq/xrx200/profiles/zyxel.mk
@@ -1,5 +1,5 @@
-define Profile/P2812HNUFX
- NAME:=ZyXEL P-2812HNU-Fx
+define Profile/P2812HNUF1
+ NAME:=ZyXEL P-2812HNU-F1
PACKAGES:=kmod-rt2800-pci wpad-mini \
kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
@@ -8,7 +8,23 @@ define Profile/P2812HNUFX
swconfig
endef
-P2812HNUFX_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
-P2812HNUFX_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+P2812HNUF1_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+P2812HNUF1_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,P2812HNUF1))
+
+define Profile/P2812HNUF3
+ NAME:=ZyXEL P-2812HNU-F3
+ PACKAGES:=kmod-rt2800-pci wpad-mini \
+ kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+ kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+ kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+ ltq-vdsl-app ppp-mod-pppoa \
+ swconfig
+endef
+
+P2812HNUF3_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+P2812HNUF3_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,P2812HNUF3))
-$(eval $(call Profile,P2812HNUFX))