summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xrx200
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-07 13:44:53 +0000
committerJohn Crispin <john@openwrt.org>2015-07-07 13:44:53 +0000
commit6bdd209f152d2c98fefabcc486dc063420cda6a9 (patch)
treeba01442cbdf1ea40480e8064dd9b974a1418bc9d /target/linux/lantiq/xrx200
parent2748df1c984e1ec105d95d42c87d67d637decdee (diff)
downloadmaster-31e0f0ae-6bdd209f152d2c98fefabcc486dc063420cda6a9.tar.gz
master-31e0f0ae-6bdd209f152d2c98fefabcc486dc063420cda6a9.tar.bz2
master-31e0f0ae-6bdd209f152d2c98fefabcc486dc063420cda6a9.zip
lantiq: Add support for the BT Home Hub 5A
u-boot support depends on the next "upstream" version ([0]) from Daniel Schwierzeck. Since the installation process is quite complicated a "how to" was added to the wiki: [1] [0] https://github.com/danielschwierzeck/u-boot-lantiq/tree/openwrt/v2014.01-next [1] http://wiki.openwrt.org/toh/bt/homehub_v5a V2: Use the correct PCI interrupt (fixes 2.4GHz wifi) Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> SVN-Revision: 46223
Diffstat (limited to 'target/linux/lantiq/xrx200')
-rw-r--r--target/linux/lantiq/xrx200/profiles/bt.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/lantiq/xrx200/profiles/bt.mk b/target/linux/lantiq/xrx200/profiles/bt.mk
new file mode 100644
index 0000000000..a1083bbb6d
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/bt.mk
@@ -0,0 +1,9 @@
+define Profile/BTHOMEHUBV5A
+ NAME:=BT Home Hub 5A
+ PACKAGES:=kmod-ath9k kmod-ath10k wpad-mini kmod-usb-dwc2
+endef
+
+BTHOMEHUBV5A_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+BTHOMEHUBV5A_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,BTHOMEHUBV5A))