summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xrx200
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-04-03 14:26:24 +0000
committerJohn Crispin <john@openwrt.org>2014-04-03 14:26:24 +0000
commit58eccdac4fb6b384dde8723876e69dafb8bf2368 (patch)
tree1cb6aa214bd126850734c1580add7a2c6aa28e36 /target/linux/lantiq/xrx200
parent78a3f697a53b9d7582d1f750ad30bfaa815808d7 (diff)
downloadmaster-31e0f0ae-58eccdac4fb6b384dde8723876e69dafb8bf2368.tar.gz
master-31e0f0ae-58eccdac4fb6b384dde8723876e69dafb8bf2368.tar.bz2
master-31e0f0ae-58eccdac4fb6b384dde8723876e69dafb8bf2368.zip
lantiq: fix vr9 ubi handling
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 40364
Diffstat (limited to 'target/linux/lantiq/xrx200')
-rw-r--r--target/linux/lantiq/xrx200/config-default2
-rw-r--r--target/linux/lantiq/xrx200/profiles/avm.mk3
-rw-r--r--target/linux/lantiq/xrx200/target.mk2
3 files changed, 5 insertions, 2 deletions
diff --git a/target/linux/lantiq/xrx200/config-default b/target/linux/lantiq/xrx200/config-default
index 4d25f21f14..4550431ee4 100644
--- a/target/linux/lantiq/xrx200/config-default
+++ b/target/linux/lantiq/xrx200/config-default
@@ -29,7 +29,7 @@ CONFIG_MTD_NAND_XWAY=y
CONFIG_MTD_UBI=y
CONFIG_MTD_UBI_BEB_LIMIT=20
# CONFIG_MTD_UBI_FASTMAP is not set
-# CONFIG_MTD_UBI_GLUEBI is not set
+CONFIG_MTD_UBI_GLUEBI=y
CONFIG_MTD_UBI_WL_THRESHOLD=4096
CONFIG_NLS=y
CONFIG_PCIE_LANTIQ=y
diff --git a/target/linux/lantiq/xrx200/profiles/avm.mk b/target/linux/lantiq/xrx200/profiles/avm.mk
index 77c1a0ad14..7eb6830bee 100644
--- a/target/linux/lantiq/xrx200/profiles/avm.mk
+++ b/target/linux/lantiq/xrx200/profiles/avm.mk
@@ -7,4 +7,7 @@ define Profile/FRITZ3370
ltq-vdsl-app ppp-mod-pppoa
endef
+FRITZ3370_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+FRITZ3370_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
$(eval $(call Profile,FRITZ3370))
diff --git a/target/linux/lantiq/xrx200/target.mk b/target/linux/lantiq/xrx200/target.mk
index 47d9be6f17..0c646685a6 100644
--- a/target/linux/lantiq/xrx200/target.mk
+++ b/target/linux/lantiq/xrx200/target.mk
@@ -5,7 +5,7 @@ FEATURES:=squashfs atm mips16 jffs2 ubifs
CPU_TYPE:=34kc
CPU_SUBTYPE:=dsp
-DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug
+DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug swconfig
define Target/Description
Lantiq XRX200