summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-4.4
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-06-13 21:50:13 +0200
committerJohn Crispin <john@phrozen.org>2016-06-14 06:43:02 +0200
commitd5666b98fa7a5e9441cf0c0977eb03f1b3611555 (patch)
tree828d7b3c5d8142f31200bf31b8082a532d6d1fa0 /target/linux/lantiq/patches-4.4
parent98d00c35e3345fd9f5eda5bc2e40ce951fa75016 (diff)
downloadmaster-31e0f0ae-d5666b98fa7a5e9441cf0c0977eb03f1b3611555.tar.gz
master-31e0f0ae-d5666b98fa7a5e9441cf0c0977eb03f1b3611555.tar.bz2
master-31e0f0ae-d5666b98fa7a5e9441cf0c0977eb03f1b3611555.zip
lantiq: fix fritz7320 wifi support
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/lantiq/patches-4.4')
-rw-r--r--target/linux/lantiq/patches-4.4/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch17
1 files changed, 13 insertions, 4 deletions
diff --git a/target/linux/lantiq/patches-4.4/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch b/target/linux/lantiq/patches-4.4/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch
index 91a884d2ea..07e6a001eb 100644
--- a/target/linux/lantiq/patches-4.4/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch
+++ b/target/linux/lantiq/patches-4.4/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch
@@ -30,7 +30,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+#endif /* _PCI_ATH_FIXUP */
--- a/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
+++ b/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
-@@ -104,5 +104,8 @@ int xrx200_gphy_boot(struct device *dev,
+@@ -104,5 +104,8 @@
extern void ltq_pmu_enable(unsigned int module);
extern void ltq_pmu_disable(unsigned int module);
@@ -41,7 +41,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
#endif /* _LTQ_XWAY_H__ */
--- a/arch/mips/lantiq/xway/Makefile
+++ b/arch/mips/lantiq/xway/Makefile
-@@ -2,4 +2,7 @@ obj-y := prom.o sysctrl.o clk.o reset.o
+@@ -2,4 +2,7 @@
obj-y += vmmc.o tffs.o
@@ -51,7 +51,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
obj-$(CONFIG_XRX200_PHY_FW) += xrx200_phy_fw.o
--- /dev/null
+++ b/arch/mips/lantiq/xway/ath_eep.c
-@@ -0,0 +1,298 @@
+@@ -0,0 +1,307 @@
+/*
+ * Copyright (C) 2011 Luca Olivetti <luca@ventoso.org>
+ * Copyright (C) 2011 John Crispin <blogic@openwrt.org>
@@ -104,6 +104,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+ const __be32 *list;
+ const char *part;
+ phandle phandle;
++ u16 dev_ids[2] = { 0 };
+
+ if ((list = of_get_property(np, "ath,eep-flash", &i)) && i == 2 *
+ sizeof(*list) && (phandle = be32_to_cpup(list++)) &&
@@ -188,6 +189,14 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+
+ }
+
++ if (!of_property_read_u16_array(np, "ath,device-id", dev_ids, 2)) {
++ struct pci_dev *d = NULL;
++
++ while ((d = pci_get_device(PCI_VENDOR_ID_ATHEROS,
++ dev_ids[0], d)) != NULL)
++ d->device = dev_ids[1];
++ }
++
+ if (!of_property_read_u32(np, "ath,led-pin", &led_pin)) {
+ ath9k_pdata.led_pin = led_pin;
+ dev_info(&pdev->dev, "using led pin %d.\n", led_pin);
@@ -615,7 +624,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+device_initcall(of_ralink_eeprom_init);
--- a/drivers/net/ethernet/lantiq_etop.c
+++ b/drivers/net/ethernet/lantiq_etop.c
-@@ -840,7 +840,11 @@ ltq_etop_init(struct net_device *dev)
+@@ -840,7 +840,11 @@
if (err)
goto err_hw;