summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.7/0117-NET-MIPS-lantiq-adds-xrx200-net.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-01-28 17:44:20 +0000
committerJohn Crispin <john@openwrt.org>2013-01-28 17:44:20 +0000
commit0de095593195b8c45dcecb4343271afbedce32df (patch)
treeb93cbf751ceb44b9b4b9500cae0cf7a2d2efc15d /target/linux/lantiq/patches-3.7/0117-NET-MIPS-lantiq-adds-xrx200-net.patch
parent0183df8ed9155b813564aafadace08ee04d64456 (diff)
downloadmaster-31e0f0ae-0de095593195b8c45dcecb4343271afbedce32df.tar.gz
master-31e0f0ae-0de095593195b8c45dcecb4343271afbedce32df.tar.bz2
master-31e0f0ae-0de095593195b8c45dcecb4343271afbedce32df.zip
refresh patches
SVN-Revision: 35355
Diffstat (limited to 'target/linux/lantiq/patches-3.7/0117-NET-MIPS-lantiq-adds-xrx200-net.patch')
-rw-r--r--target/linux/lantiq/patches-3.7/0117-NET-MIPS-lantiq-adds-xrx200-net.patch28
1 files changed, 10 insertions, 18 deletions
diff --git a/target/linux/lantiq/patches-3.7/0117-NET-MIPS-lantiq-adds-xrx200-net.patch b/target/linux/lantiq/patches-3.7/0117-NET-MIPS-lantiq-adds-xrx200-net.patch
index eb3ed5f473..478e05d061 100644
--- a/target/linux/lantiq/patches-3.7/0117-NET-MIPS-lantiq-adds-xrx200-net.patch
+++ b/target/linux/lantiq/patches-3.7/0117-NET-MIPS-lantiq-adds-xrx200-net.patch
@@ -12,11 +12,9 @@ Subject: [PATCH 117/123] NET: MIPS: lantiq: adds xrx200-net
create mode 100644 drivers/net/ethernet/lantiq_pce.h
create mode 100644 drivers/net/ethernet/lantiq_xrx200.c
-Index: linux-3.7.1/drivers/net/ethernet/Kconfig
-===================================================================
---- linux-3.7.1.orig/drivers/net/ethernet/Kconfig 2012-12-17 20:14:54.000000000 +0100
-+++ linux-3.7.1/drivers/net/ethernet/Kconfig 2012-12-21 10:30:29.629462283 +0100
-@@ -83,7 +83,13 @@
+--- a/drivers/net/ethernet/Kconfig
++++ b/drivers/net/ethernet/Kconfig
+@@ -83,7 +83,13 @@ config LANTIQ_ETOP
tristate "Lantiq SoC ETOP driver"
depends on SOC_TYPE_XWAY
---help---
@@ -31,11 +29,9 @@ Index: linux-3.7.1/drivers/net/ethernet/Kconfig
source "drivers/net/ethernet/marvell/Kconfig"
source "drivers/net/ethernet/mellanox/Kconfig"
-Index: linux-3.7.1/drivers/net/ethernet/Makefile
-===================================================================
---- linux-3.7.1.orig/drivers/net/ethernet/Makefile 2012-12-17 20:14:54.000000000 +0100
-+++ linux-3.7.1/drivers/net/ethernet/Makefile 2012-12-21 10:30:29.629462283 +0100
-@@ -36,6 +36,7 @@
+--- a/drivers/net/ethernet/Makefile
++++ b/drivers/net/ethernet/Makefile
+@@ -36,6 +36,7 @@ obj-$(CONFIG_IP1000) += icplus/
obj-$(CONFIG_JME) += jme.o
obj-$(CONFIG_KORINA) += korina.o
obj-$(CONFIG_LANTIQ_ETOP) += lantiq_etop.o
@@ -43,10 +39,8 @@ Index: linux-3.7.1/drivers/net/ethernet/Makefile
obj-$(CONFIG_NET_VENDOR_MARVELL) += marvell/
obj-$(CONFIG_NET_VENDOR_MELLANOX) += mellanox/
obj-$(CONFIG_NET_VENDOR_MICREL) += micrel/
-Index: linux-3.7.1/drivers/net/ethernet/lantiq_pce.h
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.7.1/drivers/net/ethernet/lantiq_pce.h 2012-12-21 10:30:29.629462283 +0100
+--- /dev/null
++++ b/drivers/net/ethernet/lantiq_pce.h
@@ -0,0 +1,163 @@
+/*
+ * This program is free software; you can redistribute it and/or modify it
@@ -211,10 +205,8 @@ Index: linux-3.7.1/drivers/net/ethernet/lantiq_pce.h
+ MC_ENTRY(0x0000, 0x0000, 39, OUT_NONE, 0, INSTR, FLAG_END, 0),
+ MC_ENTRY(0x0000, 0x0000, 39, OUT_NONE, 0, INSTR, FLAG_END, 0),
+};
-Index: linux-3.7.1/drivers/net/ethernet/lantiq_xrx200.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.7.1/drivers/net/ethernet/lantiq_xrx200.c 2012-12-21 12:06:26.473599462 +0100
+--- /dev/null
++++ b/drivers/net/ethernet/lantiq_xrx200.c
@@ -0,0 +1,1203 @@
+/*
+ * This program is free software; you can redistribute it and/or modify it