summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.2/0046-MIPS-lantiq-adds-GPTU-driver.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-04-17 12:50:54 +0000
committerJonas Gorski <jogo@openwrt.org>2012-04-17 12:50:54 +0000
commitee4c47a134723b78162f9f5eedc9f132dd19f6b7 (patch)
tree34e93dc39c40a016b3bf5539f7de92400e114a9b /target/linux/lantiq/patches-3.2/0046-MIPS-lantiq-adds-GPTU-driver.patch
parentcfe30549a16b84e0d7caebd94fd7c2b81261de1a (diff)
downloadmaster-31e0f0ae-ee4c47a134723b78162f9f5eedc9f132dd19f6b7.tar.gz
master-31e0f0ae-ee4c47a134723b78162f9f5eedc9f132dd19f6b7.tar.bz2
master-31e0f0ae-ee4c47a134723b78162f9f5eedc9f132dd19f6b7.zip
kernel: update linux 3.2 to 3.2.15
SVN-Revision: 31335
Diffstat (limited to 'target/linux/lantiq/patches-3.2/0046-MIPS-lantiq-adds-GPTU-driver.patch')
-rw-r--r--target/linux/lantiq/patches-3.2/0046-MIPS-lantiq-adds-GPTU-driver.patch13
1 files changed, 0 insertions, 13 deletions
diff --git a/target/linux/lantiq/patches-3.2/0046-MIPS-lantiq-adds-GPTU-driver.patch b/target/linux/lantiq/patches-3.2/0046-MIPS-lantiq-adds-GPTU-driver.patch
index 4feff7e7d6..9acda5c7da 100644
--- a/target/linux/lantiq/patches-3.2/0046-MIPS-lantiq-adds-GPTU-driver.patch
+++ b/target/linux/lantiq/patches-3.2/0046-MIPS-lantiq-adds-GPTU-driver.patch
@@ -12,9 +12,6 @@ Subject: [PATCH 46/73] MIPS: lantiq: adds GPTU driver
create mode 100644 arch/mips/include/asm/mach-lantiq/lantiq_timer.h
create mode 100644 arch/mips/lantiq/xway/timer.c
-diff --git a/arch/mips/include/asm/mach-lantiq/lantiq_timer.h b/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
-new file mode 100644
-index 0000000..ef564ab
--- /dev/null
+++ b/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
@@ -0,0 +1,155 @@
@@ -173,8 +170,6 @@ index 0000000..ef564ab
+ u32 reload, unsigned long arg1, unsigned long arg2);
+
+#endif /* __DANUBE_GPTU_DEV_H__2005_07_26__10_19__ */
-diff --git a/arch/mips/lantiq/xway/Makefile b/arch/mips/lantiq/xway/Makefile
-index 277aa34..4c3106f 100644
--- a/arch/mips/lantiq/xway/Makefile
+++ b/arch/mips/lantiq/xway/Makefile
@@ -1,4 +1,4 @@
@@ -183,8 +178,6 @@ index 277aa34..4c3106f 100644
obj-$(CONFIG_LANTIQ_MACH_EASY50712) += mach-easy50712.o
obj-$(CONFIG_LANTIQ_MACH_EASY50601) += mach-easy50601.o
-diff --git a/arch/mips/lantiq/xway/sysctrl.c b/arch/mips/lantiq/xway/sysctrl.c
-index 38f02f9..1a2e2d4 100644
--- a/arch/mips/lantiq/xway/sysctrl.c
+++ b/arch/mips/lantiq/xway/sysctrl.c
@@ -147,6 +147,7 @@ void __init ltq_soc_init(void)
@@ -195,9 +188,6 @@ index 38f02f9..1a2e2d4 100644
if (!ltq_is_vr9())
clkdev_add_pmu("ltq_etop", NULL, 0, PMU_PPE);
if (ltq_is_ase()) {
-diff --git a/arch/mips/lantiq/xway/timer.c b/arch/mips/lantiq/xway/timer.c
-new file mode 100644
-index 0000000..9794c87
--- /dev/null
+++ b/arch/mips/lantiq/xway/timer.c
@@ -0,0 +1,846 @@
@@ -1047,6 +1037,3 @@ index 0000000..9794c87
+
+module_init(lq_gptu_init);
+module_exit(lq_gptu_exit);
---
-1.7.9.1
-