summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/modules.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-03-11 08:19:53 +0000
committerJohn Crispin <john@openwrt.org>2011-03-11 08:19:53 +0000
commitc75b0ca1a8e6e9c1ffd43719792ab1903085aa93 (patch)
tree4a1a3044e0f7acb02f16849a8758e292ff66ae7d /target/linux/lantiq/modules.mk
parent58a5102338f7fde82c0a025d99f044868c979d02 (diff)
downloadmaster-31e0f0ae-c75b0ca1a8e6e9c1ffd43719792ab1903085aa93.tar.gz
master-31e0f0ae-c75b0ca1a8e6e9c1ffd43719792ab1903085aa93.tar.bz2
master-31e0f0ae-c75b0ca1a8e6e9c1ffd43719792ab1903085aa93.zip
* update kernel to .37 * add support for falcon (big thank you goes to lantiq !!)
SVN-Revision: 26021
Diffstat (limited to 'target/linux/lantiq/modules.mk')
-rw-r--r--target/linux/lantiq/modules.mk17
1 files changed, 16 insertions, 1 deletions
diff --git a/target/linux/lantiq/modules.mk b/target/linux/lantiq/modules.mk
index 78289a1a11..a4a96400d0 100644
--- a/target/linux/lantiq/modules.mk
+++ b/target/linux/lantiq/modules.mk
@@ -33,7 +33,8 @@ define KernelPackage/usb-dwc-otg
KCONFIG:=CONFIG_DWC_OTG \
CONFIG_DWC_OTG_DEBUG=n \
CONFIG_DWC_OTG_LANTIQ=y \
- CONFIG_DWC_OTG_HOST_ONLY=y
+ CONFIG_DWC_OTG_HOST_ONLY=y \
+ CONFIG_DWC_OTG_DEVICE_ONLY=n
FILES:=$(LINUX_DIR)/drivers/usb/dwc_otg/dwc_otg.ko
AUTOLOAD:=$(call AutoLoad,50,dwc_otg)
endef
@@ -44,4 +45,18 @@ endef
$(eval $(call KernelPackage,usb-dwc-otg))
+I2C_FALCON_MODULES:= \
+ CONFIG_I2C_FALCON:drivers/i2c/busses/i2c-falcon
+
+define KernelPackage/i2c-falcon-lantiq
+ TITLE:=Falcon I2C controller
+ $(call i2c_defaults,$(I2C_FALCON_MODULES),52)
+ DEPENDS:=kmod-i2c-core @TARGET_lantiq
+endef
+
+define KernelPackage/i2c-falcon-lantiq/description
+ Kernel support for the Falcon I2C controller
+endef
+
+$(eval $(call KernelPackage,i2c-falcon-lantiq))