summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/modules.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-10-10 15:13:46 +0000
committerJohn Crispin <john@openwrt.org>2011-10-10 15:13:46 +0000
commit0a866293bd9e204978c995cb0545c20f8ab63c7e (patch)
tree7d7a9ef25035a4afd4b371b85506fe062bac125a /target/linux/lantiq/modules.mk
parent1359fe4fcf0a6cef3eced837d63c866cc75a52fc (diff)
downloadmaster-31e0f0ae-0a866293bd9e204978c995cb0545c20f8ab63c7e.tar.gz
master-31e0f0ae-0a866293bd9e204978c995cb0545c20f8ab63c7e.tar.bz2
master-31e0f0ae-0a866293bd9e204978c995cb0545c20f8ab63c7e.zip
* update patches to 3.0
* add basic vr9 support * backport 3.1 fixes * backport 3.2 queue (falcon) SVN-Revision: 28405
Diffstat (limited to 'target/linux/lantiq/modules.mk')
-rw-r--r--target/linux/lantiq/modules.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/lantiq/modules.mk b/target/linux/lantiq/modules.mk
index 0d4ad2da1c..b0db10e2c7 100644
--- a/target/linux/lantiq/modules.mk
+++ b/target/linux/lantiq/modules.mk
@@ -29,7 +29,7 @@ USB_MENU:=USB Support
define KernelPackage/usb-dwc-otg
TITLE:=Synopsis DWC_OTG support
SUBMENU:=$(USB_MENU)
- DEPENDS+=@TARGET_lantiq_danube +kmod-usb-core
+ DEPENDS+=@(TARGET_lantiq_danube||TARGET_lantiq_ar9||TARGET_lantiq_vr9) +kmod-usb-core
KCONFIG:=CONFIG_DWC_OTG \
CONFIG_DWC_OTG_DEBUG=n \
CONFIG_DWC_OTG_LANTIQ=y \
@@ -51,7 +51,7 @@ I2C_FALCON_MODULES:= \
define KernelPackage/i2c-falcon-lantiq
TITLE:=Falcon I2C controller
$(call i2c_defaults,$(I2C_FALCON_MODULES),52)
- DEPENDS:=kmod-i2c-core @TARGET_lantiq
+ DEPENDS:=kmod-i2c-core @(TARGET_lantiq_falcon||TARGET_lantiq_falcon_stable)
endef
define KernelPackage/i2c-falcon-lantiq/description