summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-06-08 17:57:55 +0000
committerJohn Crispin <john@openwrt.org>2011-06-08 17:57:55 +0000
commited0e649a5b0b4664eeb85a6137542ec4c0de7513 (patch)
tree300e49443e1fb32c602242aeb9e7ce0cb70b1e60 /target/linux/lantiq/image
parent4cbdfb6d927540302db026e032a13a92cbf135d3 (diff)
downloadmaster-31e0f0ae-ed0e649a5b0b4664eeb85a6137542ec4c0de7513.tar.gz
master-31e0f0ae-ed0e649a5b0b4664eeb85a6137542ec4c0de7513.tar.bz2
master-31e0f0ae-ed0e649a5b0b4664eeb85a6137542ec4c0de7513.zip
* fixes spi flash for ar9
* adds limited support for netgear dgn3500 (enough for others to start working with) SVN-Revision: 27137
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index e73ee1936d..0e62ce5660 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -136,6 +136,14 @@ define Image/Build/Profile/ARV752DPW22
$(call Image/Build/$(1),$(1),ARV752DPW22)
endef
+define Image/BuildKernel/Profile/DGN3500B
+ $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/DGN3500B
+ $(call Image/Build/$(1),$(1),DGN3500B)
+endef
+
define Image/BuildKernel/Profile/Generic
$(call Image/BuildKernel/Template,EASY4010,$(xway_cmdline))
$(call Image/BuildKernel/Template,EASY50712,$(xway_cmdline))
@@ -149,6 +157,7 @@ define Image/BuildKernel/Profile/Generic
$(call Image/BuildKernel/Template,ARV7518PW,$(xway_cmdline))
$(call Image/BuildKernel/Template,ARV752DPW,$(xway_cmdline))
$(call Image/BuildKernel/Template,ARV752DPW22,$(xway_cmdline))
+ $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
$(call Image/BuildKernel/Template,NONE)
endef
@@ -165,6 +174,7 @@ define Image/Build/Profile/Generic
$(call Image/Build/$(1),$(1),ARV7518PW)
$(call Image/Build/$(1),$(1),ARV752DPW)
$(call Image/Build/$(1),$(1),ARV752DPW22)
+ $(call Image/Build/$(1),$(1),DGN3500B)
$(call Image/Build/$(1),$(1),NONE)
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs
endef