summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-04-27 01:13:34 +0200
committerJo-Philipp Wich <jo@mein.io>2016-04-27 01:22:32 +0200
commiteb529d26255a9a1fbeadfdaa3b5cdf47e43e4715 (patch)
treeacb8bf19872f475d0e8b08adfbc14470cb7a1842 /target/linux/lantiq/image
parent07bdd309067e794da2725a13b0ef003c4b4c13e0 (diff)
downloadmaster-31e0f0ae-eb529d26255a9a1fbeadfdaa3b5cdf47e43e4715.tar.gz
master-31e0f0ae-eb529d26255a9a1fbeadfdaa3b5cdf47e43e4715.tar.bz2
master-31e0f0ae-eb529d26255a9a1fbeadfdaa3b5cdf47e43e4715.zip
lantiq: fix xway image building
Commit 8c130dd (lantiq: use new image build process for some images) broke image generation for the xway target since the generated macros reference not existing WBMRA.dts and WBMRB.dts files leading to the following build error: mips-openwrt-linux-musl-cpp: error: ../dts/WBMRA.dts: No such file or directory mips-openwrt-linux-musl-cpp: warning: '-x assembler-with-cpp' after last input file has no effect mips-openwrt-linux-musl-cpp: fatal error: no input files Previously both the WBMRA and WBMRB profiles shared a common WBMR DT since the only difference is the embedded firmware kmod package. Extend the lantiqImage macro to optionally support specifying a different DTS file and use this facility to let the both WBMR profiles reference the correct device tree file. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index f779a1b936..67fdff683c 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -313,7 +313,7 @@ define lantiqImage
define Device/$(1)
$$(Device/lantiqImage)
DEVICE_PROFILE := $(1)
- DEVICE_DTS := $(1)
+ DEVICE_DTS := $(if $(2),$(2),$(1))
endef
TARGET_DEVICES += $(1)
endef
@@ -380,8 +380,8 @@ Image/Build/Profile/DGN3500=$(call Image/BuildDGN3500/$(1),$(1),DGN3500)
Image/BuildKernel/Profile/DGN3500B=$(call Image/BuildKernel/Template,DGN3500B)
Image/Build/Profile/DGN3500B=$(call Image/BuildDGN3500B/$(1),$(1),DGN3500B)
-$(eval $(call lantiqImage,WBMRA))
-$(eval $(call lantiqImage,WBMRB))
+$(eval $(call lantiqImage,WBMRA,WBMR))
+$(eval $(call lantiqImage,WBMRB,WBMR))
Image/BuildKernel/Profile/FRITZ7320=$(call Image/BuildKernelEVA/Template,FRITZ7320)
Image/Build/Profile/FRITZ7320=$(call Image/BuildEVA/$(1),$(1),FRITZ7320)