summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-20 14:41:54 +0000
committerJohn Crispin <john@openwrt.org>2016-03-20 14:41:54 +0000
commitd6d0597cdf2f8fc7ba305a920c20a7fb912d8401 (patch)
tree8c15f4a8db38d1c30678c3f9bbdff3279809d24d /target/linux/lantiq/image
parent217a64375547a6a5f2aba81bd1dcb0b99148c2ba (diff)
downloadmaster-31e0f0ae-d6d0597cdf2f8fc7ba305a920c20a7fb912d8401.tar.gz
master-31e0f0ae-d6d0597cdf2f8fc7ba305a920c20a7fb912d8401.tar.bz2
master-31e0f0ae-d6d0597cdf2f8fc7ba305a920c20a7fb912d8401.zip
lantiq: use upstream mechanism to append device tree file
Instead of using our patch-dtb program just place the device tree behind the kernel binary and then let the in kernel mechanism fetch it. This also adds support for having the device tree file in the boot loader. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 49050
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 882fba80f8..c3cb48afdf 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -32,8 +32,8 @@ endef
define PatchKernelLzma
cp $(KDIR)/vmlinux$(2) $(KDIR)/vmlinux$(2)-$(1)
$(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $(KDIR)/$(1).dtb ../dts/$(1).dts
- $(STAGING_DIR_HOST)/bin/patch-dtb $(KDIR)/vmlinux$(2)-$(1) $(KDIR)/$(1).dtb
- $(call CompressLzma,$(KDIR)/vmlinux$(2)-$(1),$(KDIR)/vmlinux$(2)-$(1).lzma)
+ cat $(KDIR)/vmlinux$(2)-$(1) $(KDIR)/$(1).dtb > $(KDIR)/vmlinux$(2)-$(1).tmp
+ $(call CompressLzma,$(KDIR)/vmlinux$(2)-$(1).tmp,$(KDIR)/vmlinux$(2)-$(1).lzma)
endef
define MkBrnImage